summaryrefslogtreecommitdiff
path: root/www-apps/blohg/blohg-0.13-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-08 01:28:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-08 01:28:43 +0100
commitad75ca50360f9590325f0f709c091832b70eab1d (patch)
tree8a0b109f05da2a3728e461abf6e31347c2e8b0b2 /www-apps/blohg/blohg-0.13-r4.ebuild
parent7b5e4e1f63da7fb63fba5f1a9fc41866c8ae5b2f (diff)
gentoo auto-resync : 08:10:2022 - 01:28:43
Diffstat (limited to 'www-apps/blohg/blohg-0.13-r4.ebuild')
-rw-r--r--www-apps/blohg/blohg-0.13-r4.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/www-apps/blohg/blohg-0.13-r4.ebuild b/www-apps/blohg/blohg-0.13-r4.ebuild
deleted file mode 100644
index 82259f3e10b6..000000000000
--- a/www-apps/blohg/blohg-0.13-r4.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-GIT_ECLASS=""
-if [[ ${PV} = *9999* ]]; then
- GIT_ECLASS="git-r3"
- EGIT_REPO_URI="https://github.com/rafaelmartins/blohg"
-fi
-
-inherit distutils-r1 ${GIT_ECLASS}
-
-DESCRIPTION="A Mercurial (or Git) based blogging engine"
-HOMEPAGE="https://github.com/rafaelmartins/blohg"
-
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- https://dev.gentoo.org/~rafaelmartins/distfiles/${PN}-patches-${PVR}.tar.xz"
-if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
-else
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="doc git +mercurial test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="|| ( git mercurial )
- test? ( git mercurial )"
-
-RDEPEND="
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/feedgenerator[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/flask-babel[${PYTHON_USEDEP}]
- dev-python/Frozen-Flask[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- git? ( dev-python/pygit2[${PYTHON_USEDEP}] )
- mercurial? ( >=dev-vcs/mercurial-5.2[${PYTHON_USEDEP}] )"
-
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-
-python_prepare_all() {
- if [[ ${PV} != *9999* ]]; then
- eapply "${WORKDIR}/${PN}-patches-${PVR}"
- fi
-
- if ! use git; then
- rm -rf blohg/vcs_backends/git || die 'rm failed'
- fi
-
- if ! use mercurial; then
- rm -rf blohg/vcs_backends/hg || die 'rm failed'
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
-
-python_test() {
- esetup.py test
-}