summaryrefslogtreecommitdiff
path: root/www-apps/davical/davical-1.1.9.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
commit6d691ad5b6239929063441bbd14c489e92e7396e (patch)
treee294f87b1ce66397fee1273bd6c7131aeb586f51 /www-apps/davical/davical-1.1.9.3-r1.ebuild
parentd99093fb4bb5652015c06274d64083daa2439e4f (diff)
gentoo resync : 05.03.2021
Diffstat (limited to 'www-apps/davical/davical-1.1.9.3-r1.ebuild')
-rw-r--r--www-apps/davical/davical-1.1.9.3-r1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/www-apps/davical/davical-1.1.9.3-r1.ebuild b/www-apps/davical/davical-1.1.9.3-r1.ebuild
index 4b2bc1b3ed47..b8f309f898ba 100644
--- a/www-apps/davical/davical-1.1.9.3-r1.ebuild
+++ b/www-apps/davical/davical-1.1.9.3-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit webapp
+inherit optfeature webapp
DESCRIPTION="A CalDAV and CardDAV Server"
HOMEPAGE="https://www.davical.org/"
@@ -11,13 +11,11 @@ SRC_URI="https://www.davical.org/downloads/${PN}_${PV}.orig.tar.xz -> ${P}.tar.x
LICENSE="GPL-2 GPL-2+ GPL-3+ LGPL-2.1+ LGPL-3+"
KEYWORDS="~amd64 ~x86"
-IUSE="ldap"
BDEPEND="sys-devel/gettext"
-# >=dev-lang/php-8:curly braces string offset access was removed (Bug 764908)
RDEPEND="app-admin/pwgen
- dev-lang/php[calendar,curl,iconv,imap,ldap?,nls,pdo,postgres,xml]
+ dev-lang/php[calendar,curl,iconv,imap,nls,pdo,postgres,xml]
dev-perl/DBD-Pg
dev-perl/DBI
dev-perl/YAML
@@ -70,4 +68,8 @@ pkg_postinst() {
elog " ./update-davical-database -dbuser xxxxxxx -appuser xxxxxx"
webapp_pkg_postinst
+
+ elog ""
+ elog "Optional runtime dependencies:"
+ optfeature "LDAP authentication" dev-lang/php[ldap]
}