summaryrefslogtreecommitdiff
path: root/www-apps/element/element-1.11.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-03 21:12:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-03 21:12:43 +0000
commit924750a8c767b278c9870be5dcfedced436f1276 (patch)
treed5c93de95fb5c2fa090e76fd12c1535698005868 /www-apps/element/element-1.11.13.ebuild
parenta4d4c6a7cf31d8d3248101dbfd654cdc416902ac (diff)
gentoo auto-resync : 03:11:2022 - 21:12:43
Diffstat (limited to 'www-apps/element/element-1.11.13.ebuild')
-rw-r--r--www-apps/element/element-1.11.13.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/www-apps/element/element-1.11.13.ebuild b/www-apps/element/element-1.11.13.ebuild
new file mode 100644
index 000000000000..ca2b15c5771c
--- /dev/null
+++ b/www-apps/element/element-1.11.13.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="A glossy Matrix collaboration client for the web"
+HOMEPAGE="https://element.io/"
+SRC_URI="https://github.com/vector-im/element-web/releases/download/v${PV}/${PN}-v${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+need_httpd
+
+S=${WORKDIR}/${PN}-v${PV}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/home
+ dodir "${MY_HTDOCSDIR}"/sites
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/home
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites
+ #webapp_configfile "${MY_HTDOCSDIR}"/config.json
+
+ webapp_src_install
+}