summaryrefslogtreecommitdiff
path: root/www-apps/gitea/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /www-apps/gitea/files
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'www-apps/gitea/files')
-rw-r--r--www-apps/gitea/files/gitea-logflags.patch13
-rw-r--r--www-apps/gitea/files/gitea-mod-vendor.patch46
-rw-r--r--www-apps/gitea/files/gitea.initd-r222
-rw-r--r--www-apps/gitea/files/gitea.service-r128
4 files changed, 59 insertions, 50 deletions
diff --git a/www-apps/gitea/files/gitea-logflags.patch b/www-apps/gitea/files/gitea-logflags.patch
new file mode 100644
index 000000000000..331bd3d046b1
--- /dev/null
+++ b/www-apps/gitea/files/gitea-logflags.patch
@@ -0,0 +1,13 @@
+diff --git a/modules/log/flags.go b/modules/log/flags.go
+index 992fc62..5578a1b 100644
+--- a/modules/log/flags.go
++++ b/modules/log/flags.go
+@@ -31,7 +31,7 @@ const (
+ Lmedfile = Lshortfile | Llongfile
+
+ // LstdFlags is the initial value for the standard logger
+- LstdFlags = Ldate | Ltime | Lmedfile | Lshortfuncname | Llevelinitial
++ LstdFlags = Ldate | Ltime | Llevelinitial
+ )
+
+ var flagFromString = map[string]int{
diff --git a/www-apps/gitea/files/gitea-mod-vendor.patch b/www-apps/gitea/files/gitea-mod-vendor.patch
new file mode 100644
index 000000000000..c501e20adb94
--- /dev/null
+++ b/www-apps/gitea/files/gitea-mod-vendor.patch
@@ -0,0 +1,46 @@
+diff --git a/Makefile b/Makefile
+index 796a0e3..2c6a6ef 100644
+--- a/Makefile
++++ b/Makefile
+@@ -97,7 +97,7 @@ vet:
+
+ .PHONY: generate
+ generate:
+- GO111MODULE=on $(GO) generate $(PACKAGES)
++ GO111MODULE=on $(GO) generate -mod=vendor $(PACKAGES)
+
+ .PHONY: generate-swagger
+ generate-swagger:
+diff --git a/modules/options/options.go b/modules/options/options.go
+index 723dd54..62e8c04 100644
+--- a/modules/options/options.go
++++ b/modules/options/options.go
+@@ -5,7 +5,6 @@
+ package options
+
+ //go:generate go run -mod=vendor main.go
+-//go:generate go fmt bindata.go
+
+ type directorySet map[string][]string
+
+diff --git a/modules/public/public.go b/modules/public/public.go
+index 8362b42..df70275 100644
+--- a/modules/public/public.go
++++ b/modules/public/public.go
+@@ -18,7 +18,6 @@ import (
+ )
+
+ //go:generate go run -mod=vendor main.go
+-//go:generate go fmt bindata.go
+
+ // Options represents the available options to configure the macaron handler.
+ type Options struct {
+diff --git a/modules/templates/templates.go b/modules/templates/templates.go
+index e7fe3b2..af6bf01 100644
+--- a/modules/templates/templates.go
++++ b/modules/templates/templates.go
+@@ -5,4 +5,3 @@
+ package templates
+
+ //go:generate go run -mod=vendor main.go
+-//go:generate go fmt bindata.go
diff --git a/www-apps/gitea/files/gitea.initd-r2 b/www-apps/gitea/files/gitea.initd-r2
deleted file mode 100644
index 24cac0b41f23..000000000000
--- a/www-apps/gitea/files/gitea.initd-r2
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 2016-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-description="Gitea, a self-hosted Git service"
-
-: ${GITEA_CONF:=/etc/gitea/app.ini}
-: ${GITEA_USER:=git}
-: ${GITEA_GROUP:=git}
-: ${GITEA_WORK_DIR:=/var/lib/gitea}
-: ${GITEA_CUSTOM:=${GITEA_WORK_DIR}/custom}
-
-command="/usr/bin/gitea web"
-command_args="--config ${GITEA_CONF}"
-command_background="true"
-command_user="${GITEA_USER}:${GITEA_GROUP}"
-error_log="/var/log/${RC_SVCNAME}/${RC_SVCNAME}.err"
-output_log="/var/log/${RC_SVCNAME}/${RC_SVCNAME}.log"
-pidfile="/run/${RC_SVCNAME}.pid"
-required_files="${GITEA_CONF}"
-start_stop_daemon_args="-e GITEA_WORK_DIR=${GITEA_WORK_DIR} \
- -e GITEA_CUSTOM=${GITEA_CUSTOM}"
diff --git a/www-apps/gitea/files/gitea.service-r1 b/www-apps/gitea/files/gitea.service-r1
deleted file mode 100644
index 73f924337fd6..000000000000
--- a/www-apps/gitea/files/gitea.service-r1
+++ /dev/null
@@ -1,28 +0,0 @@
-[Unit]
-Description=Gitea service
-Documentation=https://docs.gitea.io/
-
-AssertPathIsDirectory=/var/lib/gitea
-AssertPathIsReadWrite=/var/lib/gitea
-
-After=network.target
-Requires=network.target
-After=mysqld.service
-After=postgresql.service
-After=memcached.service
-After=redis.service
-
-[Service]
-User=git
-Group=git
-
-Environment="GITEA_WORK_DIR=/var/lib/gitea GITEA_CUSTOM=/var/lib/gitea/custom"
-WorkingDirectory=/var/lib/gitea
-ExecStart=/usr/bin/gitea web --config /etc/gitea/app.ini
-
-Restart=always
-PrivateTmp=true
-Nice=5
-
-[Install]
-WantedBy=multi-user.target