summaryrefslogtreecommitdiff
path: root/www-apps/icingaweb2-module-graphite
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-apps/icingaweb2-module-graphite
reinit the tree, so we can have metadata
Diffstat (limited to 'www-apps/icingaweb2-module-graphite')
-rw-r--r--www-apps/icingaweb2-module-graphite/Manifest4
-rw-r--r--www-apps/icingaweb2-module-graphite/files/patch-unquote-service.patch54
-rw-r--r--www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-9999.ebuild30
-rw-r--r--www-apps/icingaweb2-module-graphite/metadata.xml8
4 files changed, 96 insertions, 0 deletions
diff --git a/www-apps/icingaweb2-module-graphite/Manifest b/www-apps/icingaweb2-module-graphite/Manifest
new file mode 100644
index 000000000000..252efb43144d
--- /dev/null
+++ b/www-apps/icingaweb2-module-graphite/Manifest
@@ -0,0 +1,4 @@
+AUX patch-unquote-service.patch 2566 SHA256 07c1cdbeafb5726b87632be05e3f73d3a5581fa942b6cb8d925605d6bbe19e7d SHA512 6365cc7886f3b5d1ceed9b7f46a90ecc80205a0f42aa31e75b53e9384a094503a82a6a86748170af07be021eb08c0bc2ce800b8fffc961401ee3a5290c2b4297 WHIRLPOOL 4f963d1ad18d77267ad49766c9f303611df93f3063f282448b2ae36bc6197b0f67a3cd4da8d5fc5b76c5f94c9fb8e70fc0644579953e4b0c2730a81db5c08786
+EBUILD icingaweb2-module-graphite-9999.ebuild 756 SHA256 7b0dc97c7e6ea036a25a7bcb51f2ea1587b2180c5d90fc2bf6b4d3068e9585d8 SHA512 717da1e4407afcde50eafb1ce60fc1a04bbc9da3f4406d679959b34f00e46637518342bd822420a447a4a5511a682dbd5ed895819589fd2ea0e4152dfa308ecc WHIRLPOOL a9a666e673d0fe0f4be3eb034df34112638b466119fa55af5ae4c43e520f490503134d2c717ca9dec57aadfc64f6c3021e6ab95ace415499aa306d455d2e9131
+MISC ChangeLog 735 SHA256 e65cca820c9adb47681ee631fc7b290394168f81b41517d2b9b4ce12bd1e4677 SHA512 daaaf5628b81a71bdda5f510b5b28b45ba1cbf47ced9893ec97d278030bfecd0ee737970dcee47fa78d428390385bad9d6d1ebe16533a5ffa01f53d3f7fa6634 WHIRLPOOL 5dbe4079040d154c8239559e2c7d23648a66f1c0f170fc11639c459beec832ce9eb879301c89d346559926fa67f74ae725466aa53fc29171d5fa4bb469fc3555
+MISC metadata.xml 254 SHA256 62db0182648c112408826ed42fe7024fc12356fea1efd5924fb7022e50ffcffc SHA512 49faa8aa0aef31db638fe291aa55ff114f96fd9f9b2c733f88b326b44f3e9dbf627e825de7c41d45f208b2b7e5e6cd5c03e6fee3fa6013625ce7ce158bbc9a31 WHIRLPOOL 43118ddb06bdece97e50b1ed5e3fab0ebc7f884fca7a2cb7cd719ff3f6b5dbf3b9ca6090d4a6e7d554dc7d354a4cf8c7837951cab8e15590015ff5aa7242f88c
diff --git a/www-apps/icingaweb2-module-graphite/files/patch-unquote-service.patch b/www-apps/icingaweb2-module-graphite/files/patch-unquote-service.patch
new file mode 100644
index 000000000000..3dde1f45a964
--- /dev/null
+++ b/www-apps/icingaweb2-module-graphite/files/patch-unquote-service.patch
@@ -0,0 +1,54 @@
+From 3e5921b96b17ea4d0a5f32a39940a9b762e5c3a4 Mon Sep 17 00:00:00 2001
+From: Matthew Thode <mthode@mthode.org>
+Date: Tue, 12 Apr 2016 03:14:16 +0000
+Subject: [PATCH] remove quotes around $service variable
+
+This fixes https://dev.icinga.org/issues/11572
+
+This still leaves $hostname being quoted, I don't know if that needs to go as well.
+---
+ application/controllers/ShowController.php | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/application/controllers/ShowController.php b/application/controllers/ShowController.php
+index f029b81..0457ce9 100644
+--- a/application/controllers/ShowController.php
++++ b/application/controllers/ShowController.php
+@@ -168,7 +168,7 @@ public function hostAction()
+ if (! array_key_exists('icingaHost', $patterns)) continue;
+
+ foreach ($set->loadTemplates() as $key => $template) {
+- if (strpos($template->getFilterString(), '$service') !== false) continue;
++ if (strpos($template->getFilterString(), $service) !== false) continue;
+
+ $imgParams = array(
+ 'template' => $key,
+@@ -228,7 +228,7 @@ public function serviceAction()
+ if (! array_key_exists('icingaHost', $patterns)) continue;
+
+ foreach ($set->loadTemplates() as $key => $template) {
+- if (strpos($template->getFilterString(), '$service') === false) continue;
++ if (strpos($template->getFilterString(), $service) === false) continue;
+
+ $imgParams = array(
+ 'template' => $key,
+@@ -289,7 +289,7 @@ public function XXXserviceAction()
+
+ foreach ($set->loadTemplates() as $key => $template) {
+
+- if (strpos($template->getFilterString(), '$service') === false) continue;
++ if (strpos($template->getFilterString(), $service) === false) continue;
+
+ $this->view->templates[$key] = $template;
+
+diff -Naur a/library/Graphite/ProvidedHook/Monitoring/ServiceActions.php b/library/Graphite/ProvidedHook/Monitoring/ServiceActions.php
+--- a/library/Graphite/ProvidedHook/Monitoring/ServiceActions.php 2016-10-16 19:10:49.794640399 -0500
++++ b/library/Graphite/ProvidedHook/Monitoring/ServiceActions.php 2016-10-16 19:11:17.136401235 -0500
+@@ -16,6 +16,7 @@
+ array(
+ 'host' => $service->host_name,
+ 'service' => $service->service_description,
++ 'check_command' => $service->service_check_command,
+ ))
+ );
+ }
diff --git a/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-9999.ebuild b/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-9999.ebuild
new file mode 100644
index 000000000000..7e359c940e4c
--- /dev/null
+++ b/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Icinga Web 2 plugin for pnp4nagios"
+HOMEPAGE="http://www.icinga.org/"
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-graphite.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ MY_PN="icingaweb2-module-pnp"
+ SRC_URI="https://codeload.github.com/Icinga/${MY_PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ >=www-apps/icingaweb2-2.0.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/patch-unquote-service.patch" )
+
+src_install() {
+ insinto "/usr/share/icingaweb2/modules/graphite/"
+ doins -r "${S}"/*
+}
diff --git a/www-apps/icingaweb2-module-graphite/metadata.xml b/www-apps/icingaweb2-module-graphite/metadata.xml
new file mode 100644
index 000000000000..3ffdeb4af3b5
--- /dev/null
+++ b/www-apps/icingaweb2-module-graphite/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+</pkgmetadata>