summaryrefslogtreecommitdiff
path: root/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-1.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-06 00:00:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-06 00:00:52 +0100
commit43c2a85d4e20318dd3d35872e348707900870067 (patch)
treef863318f1d5bf6641145c6eb96a25818842ba87f /www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-1.0.1-r1.ebuild
parentb594445f39d99066071d80fc8efeba5c8f72cc35 (diff)
gentoo auto-resync : 06:05:2024 - 00:00:51
Diffstat (limited to 'www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-1.0.1-r1.ebuild')
-rw-r--r--www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-1.0.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-1.0.1-r1.ebuild b/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..82cd50c21cf1
--- /dev/null
+++ b/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-1.0.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Icinga Web 2 plugin for pnp4nagios"
+HOMEPAGE="https://icinga.org/"
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-pnp.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ MY_PN="icingaweb2-module-pnp"
+ SRC_URI="https://codeload.github.com/Icinga/${MY_PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ >=www-apps/icingaweb2-2.0.0"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto "/usr/share/icingaweb2/modules/pnp"
+ doins -r "${S}"/*
+}