summaryrefslogtreecommitdiff
path: root/www-apps/icingaweb2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
commit407525b571b48cfd65e1ad7a02d250a927c967c9 (patch)
tree844bea44d85dc7218f54970af1c42cc9d55c3f1a /www-apps/icingaweb2
parent89c6c06b8c42107dd231687a1012354e7d3039fc (diff)
gentoo resync : 01.12.2017
Diffstat (limited to 'www-apps/icingaweb2')
-rw-r--r--www-apps/icingaweb2/Manifest4
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.5.0.ebuild79
2 files changed, 82 insertions, 1 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index 53fd0a271df1..0a5062f5c602 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1,4 +1,6 @@
-DIST icingaweb2-2.4.2.tar.gz 7180122 SHA256 8ce42b4f0fb3ddd93c56d70c642512af13db1d5db2ad0227ec7567a4413daa94 SHA512 2a6f80561b59fde1b7ca72b8a120f93685a4741e7af036a90cdd5a1371f8e6d6caa25161f136b379255032b16b21914325a26f078121743d1299e96e7685ef53 WHIRLPOOL 0f350e796e5b03c5d3e0c501cdae8c485c2eb745da87e308f57066cfe507d24482799ab9e6fe1ed621c19f14fcca3b97c7f57d67a28ac51e42c13aa7094afe83
+DIST icingaweb2-2.4.2.tar.gz 7180122 BLAKE2B d3018ab2bbb9cbe501c638208d7546640b83775ef86e340b61c9a83bc8f250060c34a7dae74cc983252ff05747d951107ff5c7857aaa44dc387ce513843c503f SHA512 2a6f80561b59fde1b7ca72b8a120f93685a4741e7af036a90cdd5a1371f8e6d6caa25161f136b379255032b16b21914325a26f078121743d1299e96e7685ef53
+DIST icingaweb2-2.5.0.tar.gz 8032968 BLAKE2B f0fab047da90ff514f715a8ddbf51d97beb1cd052513a523c63fbb97a424ecee8ff7b2c63a6e432cda3d70bdb1283641702d3ae1ff4146d084b312009ccdbe5e SHA512 9946c74033550accdc7077b3f77ce035931c72645871808ea488113d3545f8082460c1b8a4dffcb08f01d452fab54fd425e90e77cd006a7783b426132015498f
EBUILD icingaweb2-2.4.2.ebuild 2549 BLAKE2B b20f1ce38a44e2066fe321d6d8a86a95976a52648c2d4ba0e24073e2040a755634c9747708c384fa29855e1ce3ab088eb39a9b644547fbed5d78632e239246db SHA512 45e388216b6b4b25facf2a46fed4385f47455023cdc6fff6586a8801c6f1aabc7a13e1330f9e6a56e3acd9f4c7bce724411049fb0245aa6d3295c0dba45e6c33
+EBUILD icingaweb2-2.5.0.ebuild 2551 BLAKE2B 66cc7c475232d4dd323505acfff732fb960c5a0e3774f5a1343dc0e43f2c7c6a5ec56ca77d7803be067fa9786e63f492610593507d9a05afe3dd3c1a98b75c59 SHA512 4b59c96f553f19d648c4444e94372f88bb69da38c8f1d9e8d5c57a4720f48ce81e1f72742a2db29f8c5e8f02b3323457abc96b80f7b737cee2418721034dce12
EBUILD icingaweb2-9999.ebuild 2546 BLAKE2B a5a883a093e6a88e99d357b65a5d7367719d40fa98d7d8ab530147631448f033ec0858481575bb5a981f0126bf650d7862ea5c283ff9add93325ec640b28034c SHA512 fa08a2c6d47a9b1df8027dba57b7b8be8bad1980af3c45af52203435dc98ce28b47ec211691e241bda8913dcd77370004ef1b24622fabae8cc3d510f3f9decbc
MISC metadata.xml 407 BLAKE2B 42e1ae67b6d8307c3af6ee7257eb811d893705aedd5852c4b33b103d77bbb4858d01bf8369511d7ce1cc187158482755894583d3b77be0ca7580043279f96461 SHA512 40eb3b6ff856fb8a4bcced4b177c73e4a7987b468dbcfe645d4a9f816f100ce899c8f8f803ad343c2b33b60cbcfbd4cef37257548311d22b4272a15602b1c961
diff --git a/www-apps/icingaweb2/icingaweb2-2.5.0.ebuild b/www-apps/icingaweb2/icingaweb2-2.5.0.ebuild
new file mode 100644
index 000000000000..9c54138b2b4f
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.5.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit depend.apache eutils multilib user
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 ldap mysql nginx pdf postgres"
+REQUIRED_USE="^^ ( apache2 nginx )"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-php/pecl-imagick
+ pdf? ( media-gfx/imagemagick[png] )
+ apache2? (
+ >=www-servers/apache-2.4.0
+ || (
+ dev-lang/php:5.6[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.0[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.1[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ )
+ nginx? (
+ >=www-servers/nginx-1.7.0:*
+ || (
+ dev-lang/php:5.6[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.0[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.1[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ )"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ enewgroup icingaweb2
+ enewgroup icingacmd
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ fperms -R a+rX "/usr/share/${PN}/public/"
+ fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}