summaryrefslogtreecommitdiff
path: root/www-apps/jellyfin/jellyfin-10.8.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-24 01:01:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-24 01:01:06 +0000
commitf52562a45d967e193210737b55de5f0ff9018b76 (patch)
tree909caa133f3a538fde8ed9dfd9efa42a2c7a0507 /www-apps/jellyfin/jellyfin-10.8.13.ebuild
parent36fc50e36ed1a4686bb7202aeaff3170b2206124 (diff)
gentoo auto-resync : 24:03:2024 - 01:01:06
Diffstat (limited to 'www-apps/jellyfin/jellyfin-10.8.13.ebuild')
-rw-r--r--www-apps/jellyfin/jellyfin-10.8.13.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/www-apps/jellyfin/jellyfin-10.8.13.ebuild b/www-apps/jellyfin/jellyfin-10.8.13.ebuild
deleted file mode 100644
index 39218e469f00..000000000000
--- a/www-apps/jellyfin/jellyfin-10.8.13.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit pax-utils systemd tmpfiles
-
-DESCRIPTION="Jellyfin puts you in control of managing and streaming your media"
-HOMEPAGE="https://jellyfin.readthedocs.io/en/latest/"
-
-SRC_URI="
- arm64? (
- https://repo.jellyfin.org/releases/server/linux/versions/stable/combined/${PV}/${PN}_${PV}_arm64.tar.gz
- https://repo.jellyfin.org/archive/linux/stable/${PV}/combined/${PN}_${PV}_arm64.tar.gz
- )
- amd64? (
- https://repo.jellyfin.org/releases/server/linux/versions/stable/combined/${PV}/${PN}_${PV}_amd64.tar.gz
- https://repo.jellyfin.org/archive/linux/stable/${PV}/combined/${PN}_${PV}_amd64.tar.gz
- )"
-
-RESTRICT="mirror test"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~arm64"
-DEPEND="acct-user/jellyfin
- media-libs/fontconfig
- sys-libs/zlib"
-RDEPEND="${DEPEND}
- dev-libs/icu
- media-video/ffmpeg[vpx,x264]
- sys-libs/glibc"
-BDEPEND="acct-user/jellyfin"
-INST_DIR="/opt/${PN}"
-QA_PREBUILT="${INST_DIR#/}/*.so ${INST_DIR#/}/jellyfin ${INST_DIR#/}/createdump"
-
-src_unpack() {
- unpack ${A}
- mv ${PN}_${PV} ${P} || die
-}
-
-src_prepare() {
- default
-
- # https://github.com/jellyfin/jellyfin/issues/7471
- # https://github.com/dotnet/runtime/issues/57784
- rm libcoreclrtraceptprovider.so || die
-}
-
-src_install() {
- keepdir /var/log/jellyfin
- fowners jellyfin:jellyfin /var/log/jellyfin
- keepdir /etc/jellyfin
- fowners jellyfin:jellyfin /etc/jellyfin
- insinto ${INST_DIR}
- dodir ${INST_DIR}
- doins -r "${S}"/*
- newtmpfiles - jellyfin.conf <<<"d /var/cache/jellyfin 0775 jellyfin jellyfin -"
- chmod 755 "${D}${INST_DIR}/jellyfin"
- newinitd "${FILESDIR}/${PN}.init-r1" "${PN}"
- newconfd "${FILESDIR}"/${PN}.confd "${PN}"
- systemd_dounit "${FILESDIR}/${PN}.service"
- pax-mark -m "${ED}${INST_DIR}/jellyfin"
-}
-
-pkg_postinst() {
- tmpfiles_process jellyfin.conf
-}