summaryrefslogtreecommitdiff
path: root/www-apps/karma-bin/karma-bin-0.40.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /www-apps/karma-bin/karma-bin-0.40.ebuild
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'www-apps/karma-bin/karma-bin-0.40.ebuild')
-rw-r--r--www-apps/karma-bin/karma-bin-0.40.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/www-apps/karma-bin/karma-bin-0.40.ebuild b/www-apps/karma-bin/karma-bin-0.40.ebuild
new file mode 100644
index 000000000000..208ce387b321
--- /dev/null
+++ b/www-apps/karma-bin/karma-bin-0.40.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+MY_PN=${PN%-bin}
+
+inherit user
+
+DESCRIPTION="Alerts dashboard for Prometheus Alertmanager"
+HOMEPAGE="https://github.com/prymitive/karma"
+SRC_URI="https://github.com/prymitive/${MY_PN}/releases/download/v${PV}/${MY_PN}-linux-amd64.tar.gz -> ${P}-amd64.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+QA_PREBUILT="usr/bin/*"
+RESTRICT="strip"
+S="${WORKDIR}"
+
+pkg_setup() {
+ enewgroup ${MY_PN}
+ enewuser ${MY_PN} -1 -1 -1 ${MY_PN}
+}
+
+src_install() {
+ dobin karma-linux-amd64
+ dosym karma-linux-amd64 /usr/bin/karma
+ insinto /etc/${MY_PN}
+ newins "${FILESDIR}"/${MY_PN}-0.24.yaml ${MY_PN}.yaml
+ newinitd "${FILESDIR}"/${MY_PN}.initd ${MY_PN}
+keepdir /var/log/${MY_PN}
+fowners ${MY_PN}:${MY_PN} /var/log/${MY_PN}
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Please edit ${EROOT}/etc/karma/karma.yaml to match your system."
+ fi
+}