summaryrefslogtreecommitdiff
path: root/www-apps/klaus/klaus-2.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-14 15:13:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-14 15:13:45 +0100
commitb9e8f3cc44aed3b6da71c7510c6287bf7bbbc66b (patch)
tree4b47f3026f10252cff69e7a4346215a4da4f0f1c /www-apps/klaus/klaus-2.0.3.ebuild
parent3d952d0bfe7b386699eb32d1431deb0c538f044d (diff)
gentoo auto-resync : 14:06:2023 - 15:13:45
Diffstat (limited to 'www-apps/klaus/klaus-2.0.3.ebuild')
-rw-r--r--www-apps/klaus/klaus-2.0.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/www-apps/klaus/klaus-2.0.3.ebuild b/www-apps/klaus/klaus-2.0.3.ebuild
new file mode 100644
index 000000000000..af488c89f7ae
--- /dev/null
+++ b/www-apps/klaus/klaus-2.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A simple, easy-to-set-up Git web viewer"
+HOMEPAGE="https://github.com/jonashaag/klaus/"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ctags"
+
+# Tests can only be run from a git repository so they are not included in
+# source distributions.
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/dulwich-0.19.3[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/httpauth[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ ctags? ( dev-python/python-ctags3[${PYTHON_USEDEP}] )
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}