summaryrefslogtreecommitdiff
path: root/www-apps/nextcloud/nextcloud-26.0.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-04 05:43:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-04 05:43:52 +0000
commit355555b18ef39d8b98821fb28be5a0577f24acab (patch)
treee2bd2d970fb0a11a0653e6fab7b29671a6766b13 /www-apps/nextcloud/nextcloud-26.0.11.ebuild
parent9becec60cd1423a327b86686a981699c0522cd79 (diff)
gentoo auto-resync : 04:02:2024 - 05:43:52
Diffstat (limited to 'www-apps/nextcloud/nextcloud-26.0.11.ebuild')
-rw-r--r--www-apps/nextcloud/nextcloud-26.0.11.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/www-apps/nextcloud/nextcloud-26.0.11.ebuild b/www-apps/nextcloud/nextcloud-26.0.11.ebuild
new file mode 100644
index 000000000000..2d28ed73cfa3
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-26.0.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+RDEPEND="<dev-lang/php-8.2[curl?,filter,gd,hash(+),intl,json(+),mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}