summaryrefslogtreecommitdiff
path: root/www-apps/nextcloud/nextcloud-26.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-17 03:31:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-17 03:31:10 +0100
commit280d9db9f9470686aae5ce1fa4cfa57b26e9beb2 (patch)
tree604fa555cdb815d5774494412f041887debf5220 /www-apps/nextcloud/nextcloud-26.0.5.ebuild
parent2ef316f0ffbd90d833effd2d09d1232e5767e321 (diff)
gentoo auto-resync : 17:08:2023 - 03:31:10
Diffstat (limited to 'www-apps/nextcloud/nextcloud-26.0.5.ebuild')
-rw-r--r--www-apps/nextcloud/nextcloud-26.0.5.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/www-apps/nextcloud/nextcloud-26.0.5.ebuild b/www-apps/nextcloud/nextcloud-26.0.5.ebuild
new file mode 100644
index 000000000000..e9db891d0021
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-26.0.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="<dev-lang/php-8.2[curl?,filter,gd,hash(+),intl,json(+),mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}