summaryrefslogtreecommitdiff
path: root/www-apps/novnc/novnc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-19 20:11:46 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-19 20:11:46 +0000
commit5b5df25227111ef465caf5c52bcfb66dac3219cd (patch)
tree31b713cac6188358125cbb66b8804030328740f0 /www-apps/novnc/novnc-9999.ebuild
parent02e2208f46f4e2c00fb9743cbc47350bdd233bfa (diff)
gentoo resync : 19.01.2018
Diffstat (limited to 'www-apps/novnc/novnc-9999.ebuild')
-rw-r--r--www-apps/novnc/novnc-9999.ebuild47
1 files changed, 20 insertions, 27 deletions
diff --git a/www-apps/novnc/novnc-9999.ebuild b/www-apps/novnc/novnc-9999.ebuild
index 3bcb1d55fc69..fb8b22ba491e 100644
--- a/www-apps/novnc/novnc-9999.ebuild
+++ b/www-apps/novnc/novnc-9999.ebuild
@@ -1,20 +1,27 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit distutils-r1 git-2
+inherit distutils-r1
DESCRIPTION="noVNC is a VNC client implemented using HTML5 technologies"
HOMEPAGE="https://kanaka.github.com/noVNC/"
-EGIT_REPO_URI="https://github.com/kanaka/noVNC.git"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kanaka/noVNC.git"
+else
+ SRC_URI="https://github.com/kanaka/noVNC/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+fi
+
S="${WORKDIR}/noVNC-${PV}"
LICENSE="LGPL-3"
SLOT="0"
-KEYWORDS=""
IUSE=""
DEPEND=""
@@ -27,28 +34,14 @@ python_compile() {
}
src_install() {
- dodir /usr/share/novnc/utils
- dodir /usr/share/novnc/include
- dodir /usr/share/novnc/images
-
exeinto /usr/share/novnc/utils
- doexe utils/b64-to-binary.pl
- doexe utils/img2js.py
- doexe utils/inflator.partial.js
- doexe utils/json2graph.py
- doexe utils/launch.sh
- doexe utils/parse.js
- doexe utils/u2x11
-
- docinto /usr/share/novnc/docs
- dodoc README.md
- dodoc LICENSE.txt
-
- cp -pPR *.html "${D}/usr/share/novnc/"
- cp -pPR include/* "${D}/usr/share/novnc/include/"
- cp -pPR images/* "${D}/usr/share/novnc/images/"
- dosym images/favicon.ico /usr/share/novnc/favicon.ico
+ for f in utils/*; do
+ [[ ! f = utils/README.md ]] && doexe $f
+ done
+
+ dodoc README.md LICENSE.txt
- newconfd "${FILESDIR}/noVNC.confd" noVNC
- newinitd "${FILESDIR}/noVNC.initd" noVNC
+ insinto /usr/share/novnc
+ doins -r *.html include/ images/
+ dosym images/favicon.ico /usr/share/novnc/favicon.ico
}