summaryrefslogtreecommitdiff
path: root/www-apps/postfixadmin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /www-apps/postfixadmin
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'www-apps/postfixadmin')
-rw-r--r--www-apps/postfixadmin/Manifest2
-rw-r--r--www-apps/postfixadmin/postfixadmin-3.3.9.ebuild107
2 files changed, 109 insertions, 0 deletions
diff --git a/www-apps/postfixadmin/Manifest b/www-apps/postfixadmin/Manifest
index 497d19f76ecc..896d5ae60ddc 100644
--- a/www-apps/postfixadmin/Manifest
+++ b/www-apps/postfixadmin/Manifest
@@ -1,4 +1,6 @@
AUX postinstall-en-2.3.txt 1827 BLAKE2B 49402566ddf6981cf0226f6a963fdd2c482957903583807f5c42731dfd5b4aea56de7d1ebd47ab6909f12492bd5e7a788322e0b2d80e15d883483a080f8fe11c SHA512 59e304d63830227b1619ed1299e9b61f5b6e534cb03da4d3a0e35a0fe727ccf2d994a034bd12d515bba4f8a6a8ca513cf2131c031fa63f85906639aca159993a
DIST postfixadmin-3.3.8.tar.gz 1865581 BLAKE2B f8b29248e839d973fd72647747e0bba7452676543f44310f12203d5e64e83222a3992e282a3898fa077dc54100b3446e4d1cded56cd464d72b2997ce34f064db SHA512 bfe5d874083568f1e8b1830394338d2aa29e39e30834d4c8c728836495f12f6d49c65b83b1fae1fce20e7456afaef0058320033866b720a5858911ceec22a022
+DIST postfixadmin-3.3.9.tar.gz 1866167 BLAKE2B 28546631dce340d3c1128b525de1c33e9e3aa23cd557e6c8f7e9b26f97aedba67f2e5f3ea351e0db2d79e068e16cfa1672cbe3e6abbffd19e5009e2a9df84523 SHA512 791b05df34a4f2eec01fe6f6b9038a6630cd60c42e1f2e725fe3d033a692b77d2d688858b947c53d1ce48258c7c87a2e3fb31356e553632b88149d5a29bfa70e
EBUILD postfixadmin-3.3.8.ebuild 2978 BLAKE2B 3339b2f17788c81245e9c6315fc99e70e39fc4a55412af0ed1ae7ecf52a81a1e012e79d65c7a2f35c613ccfd050066275dd0e1ebee6b0fcf2f9a6623fb6b955a SHA512 edfef8358f540a0293fe3a6b10f7c420dbd934673e2afa4007a32544ccf173fb7843942518e3760a4a848638aa372ccf4fa5a832f91caa6bbed49076130e7576
+EBUILD postfixadmin-3.3.9.ebuild 2980 BLAKE2B 13d801092bb1b4206d00eebb0d6cb184c271560a8d827f5b30adbf91727323180faedf42d47d1219f08a35cb54de030e825595f843dcdbd8e7abdfc53e669bbe SHA512 2264b4f9af839aacc07e90797d2ca59022014546443cc079e78aca48124e1d5b56c68f32099cd53029de61dc3447c01506683a9d2dced77266b4bae054dc6e89
MISC metadata.xml 560 BLAKE2B 2dccae38d76ef72520678dcc26582c6d99d2221c8cad753063e4948b75cd84b39f47b854a010217a6a52186a7308a3355c41ab6a7229af2417deb39ccb3eae84 SHA512 4ab5d3db2584f100b9f1d9729eb50487e40b27d16c436cbe09dd03d24c533d5d7c61b4b19eda03aa423fb34d9cf2b9f3ec55679196bb8e8da5ea3157c0bc567b
diff --git a/www-apps/postfixadmin/postfixadmin-3.3.9.ebuild b/www-apps/postfixadmin/postfixadmin-3.3.9.ebuild
new file mode 100644
index 000000000000..0df1b6d26679
--- /dev/null
+++ b/www-apps/postfixadmin/postfixadmin-3.3.9.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit user webapp
+
+DESCRIPTION="Web Based Management tool for Postfix style virtual domains and users"
+HOMEPAGE="http://postfixadmin.sourceforge.net"
+SRC_URI="https://github.com/postfixadmin/postfixadmin/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+mysql postgres +vacation"
+REQUIRED_USE="|| ( mysql postgres )"
+
+DEPEND="
+ dev-lang/php:*[unicode,imap,postgres?]
+ vacation? (
+ dev-perl/DBI
+ dev-perl/Email-Sender
+ dev-perl/Email-Valid
+ dev-perl/Log-Dispatch
+ dev-perl/Log-Log4perl
+ dev-perl/MIME-Charset
+ dev-perl/MIME-EncWords
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )
+ )
+"
+RDEPEND="${DEPEND}
+ virtual/httpd-php
+ mysql? ( || ( dev-lang/php[mysqli] dev-lang/php[mysql] ) )"
+
+S="${WORKDIR}/${PN}-${P}"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if use vacation; then
+ enewgroup vacation
+ enewuser vacation -1 -1 -1 vacation
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ if use vacation; then
+ insinto /var/spool/vacation
+ newins VIRTUAL_VACATION/vacation.pl vacation.pl-${SLOT}
+ fowners vacation:vacation /var/spool/vacation/vacation.pl-${SLOT}
+ fperms 770 /var/spool/vacation/vacation.pl-${SLOT}
+ dodoc VIRTUAL_VACATION/FILTER_README
+ newdoc VIRTUAL_VACATION/INSTALL.md VIRTUAL_VACATION_INSTALL.md
+ rm -r VIRTUAL_VACATION/{vacation.pl,INSTALL.md,tests,FILTER_README} || die
+ fi
+
+ docinto /usr/share/doc/${PF}/
+ dodoc -r ADDITIONS
+
+ local docs="DOCUMENTS/*.txt INSTALL.TXT CHANGELOG.TXT"
+ dodoc ${docs}
+
+ rm -rf ${docs} DOCUMENTS/ GPL-LICENSE.TXT LICENSE.TXT debian/ tests/ ADDITIONS/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.inc.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-2.3.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ einfo "Please note that if upgrading from version prior to 3.3.0,"
+ einfo "existing setup_password will no longer work and you will"
+ einfo "need to generate new one. See instructions in setup.php."
+
+ if use vacation; then
+ # portage does not update owners of directories (feature :)
+ chown vacation:vacation "${ROOT}"/var/spool/vacation/
+ einfo
+ einfo "/var/spool/vacation/vacation.pl symlink was updated to:"
+ einfo "/var/spool/vacation/vacation.pl-${SLOT}"
+ ln -sf "${ROOT}"/var/spool/vacation/vacation.pl{-${SLOT},} || die
+ fi
+}
+
+pkg_postrm() {
+ # Make sure we don't leave broken vacation.pl symlink
+ find -L "${ROOT}"/var/spool/vacation/ -type l -delete
+ local shopt_save=$(shopt -p nullglob)
+ shopt -s nullglob
+ local vacation=( "${ROOT}"/var/spool/vacation/vacation.pl-* )
+ ${shopt_save}
+ if [[ ! -e "${ROOT}"/var/spool/vacation/vacation.pl && -n ${vacation[@]} ]]; then
+ ln -s "${vacation[-1]}" "${ROOT}"/var/spool/vacation/vacation.pl || die
+ ewarn "/var/spool/vacation/vacation.pl was updated to point on most"
+ ewarn "recent verion, but please, do your own checks"
+ fi
+}