summaryrefslogtreecommitdiff
path: root/www-apps/sfpg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /www-apps/sfpg
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'www-apps/sfpg')
-rw-r--r--www-apps/sfpg/Manifest3
-rw-r--r--www-apps/sfpg/metadata.xml17
-rw-r--r--www-apps/sfpg/sfpg-4.9.0.ebuild44
3 files changed, 64 insertions, 0 deletions
diff --git a/www-apps/sfpg/Manifest b/www-apps/sfpg/Manifest
new file mode 100644
index 000000000000..a4c9ee473fb5
--- /dev/null
+++ b/www-apps/sfpg/Manifest
@@ -0,0 +1,3 @@
+DIST Single_File_PHP_Gallery_4.9.0.zip 43058 BLAKE2B 27eb6362f28b1d24d77d8e9ccfdf83814ca4de0c0e1a2d1a94345e6c4b0c5b95b223c2bf5186f64a83fae392d2f8bdf7eb4e77c5295a86b279ce0abc7cb625cf SHA512 511889ff9c8680dd49d5c982609508b73c9baa5a2d8f7e8f6642003ce9e9f1feec248d9da3c69a4363ddc7ef6c77652697c0fa30f51ba490c2c926428ac8482c
+EBUILD sfpg-4.9.0.ebuild 698 BLAKE2B 138b1f50a10ca4a6c9c366f3ef41a4128b5e4ec0b70cfa2fed87c7d61850ccdee3c0cbce05fc08eba5fe61379e58dc73967f77c45c7e9300f62ad545989d43e8 SHA512 563890f10b490e2b41836997b7aa6a5606bdb61406c57ea9c22280abd476a1c3470d916878ec43372808cbc7de964451ad74b8a335f62d873246cdf6bee829e8
+MISC metadata.xml 678 BLAKE2B 568c3e59e07172135e4710ad262ee1f4da210956412c7fffb631b3f18a2b916a89bd0a5723bab61ee36329d69475af7473d6d2eed826cc31e865fd7f833748cc SHA512 5bda46cc0ec8ba599351ba9290429abfe2ca7624e5197dab9cd797dac3271b2951b81a6cb3d7470ba0980a967fc48dc21bd1194ac436a8c1173b34dc75b85e46
diff --git a/www-apps/sfpg/metadata.xml b/www-apps/sfpg/metadata.xml
new file mode 100644
index 000000000000..8d38f85fa08c
--- /dev/null
+++ b/www-apps/sfpg/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <longdescription>
+ Single File PHP Gallery is a web gallery in one single PHP file.
+ All you have to do is copy the script to any directory containing
+ images to make a gallery. Sub directories will be sub galleries.
+ Thumbnails for images and directories are generated automatically.
+ Single File PHP Gallery does not require any configuration
+ or programming skills to use.
+ </longdescription>
+</pkgmetadata>
diff --git a/www-apps/sfpg/sfpg-4.9.0.ebuild b/www-apps/sfpg/sfpg-4.9.0.ebuild
new file mode 100644
index 000000000000..b57ac1408b7d
--- /dev/null
+++ b/www-apps/sfpg/sfpg-4.9.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+MY_PN="${PN^^}"
+MY_PV="fd8fa70739d18d786e88f7ffa57e250e0e41af8f"
+
+DESCRIPTION="A web gallery in one single PHP file"
+HOMEPAGE="https://sye.dk/sfpg/"
+SRC_URI="https://sye.dk/sfpg/Single_File_PHP_Gallery_${PV}.zip"
+S="${WORKDIR}"
+
+LICENSE="sfpg"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ dev-lang/php[gd]
+ virtual/httpd-php
+"
+
+BDEPEND="app-arch/unzip"
+
+need_httpd_cgi
+
+DOCS=( "readme.txt" )
+
+src_install() {
+ webapp_src_preinst
+
+ einstalldocs
+
+ insinto "${MY_HTDOCSDIR}"
+ doins index.php
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+}