summaryrefslogtreecommitdiff
path: root/www-apps/trickster/trickster-0.1.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /www-apps/trickster/trickster-0.1.9.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'www-apps/trickster/trickster-0.1.9.ebuild')
-rw-r--r--www-apps/trickster/trickster-0.1.9.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/www-apps/trickster/trickster-0.1.9.ebuild b/www-apps/trickster/trickster-0.1.9.ebuild
new file mode 100644
index 000000000000..d147b62d604c
--- /dev/null
+++ b/www-apps/trickster/trickster-0.1.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit user systemd
+
+DESCRIPTION="Dashboard Accelerator for Prometheus"
+HOMEPAGE="https://github.com/Comcast/trickster"
+VENDOR_URI="https://dev.gentoo.org/~williamh/dist/${P}-vendor.tar.gz"
+SRC_URI="https://github.com/Comcast/trickster/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${VENDOR_URI}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-lang/go:="
+
+RESTRICT="strip"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_prepare() {
+ default
+ mv ../vendor .
+}
+
+src_compile() {
+ set -- env GOCACHE="${T}"/go-cache go build -a -mod vendor -v
+ echo $@
+ "$@" || die "build failed"
+}
+
+src_install() {
+ dobin ${PN}
+dodoc -r conf docs/*
+ systemd_dounit conf/trickster.service
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+ insinto /etc/trickster
+ doins "${FILESDIR}"/${PN}.conf
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+}