summaryrefslogtreecommitdiff
path: root/www-apps/xpra-html5
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-29 16:01:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-29 16:01:29 +0100
commit9cd7e710ac676c1a318d09e665ca3558bb5c5323 (patch)
treee9be71b324835aa5fe0d86769dc47ba880e3313b /www-apps/xpra-html5
parent8ba401288d74259a5fd8e9de5241dd57a0a73b1f (diff)
gentoo auto-resync : 29:10:2022 - 16:01:29
Diffstat (limited to 'www-apps/xpra-html5')
-rw-r--r--www-apps/xpra-html5/Manifest2
-rw-r--r--www-apps/xpra-html5/xpra-html5-6.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/www-apps/xpra-html5/Manifest b/www-apps/xpra-html5/Manifest
index 9cfc5a137c1a..1b5005742a54 100644
--- a/www-apps/xpra-html5/Manifest
+++ b/www-apps/xpra-html5/Manifest
@@ -1,3 +1,5 @@
DIST xpra-html5-5.0.tar.gz 1570694 BLAKE2B aef7b818aa618c143701993627e629884b5e696c7334e6b75701a20028f18aced5e3249505ac031d6cd0a08d79ca2b9728afdb2e90712fcbe45d43d02598f608 SHA512 8318c6dd8f8f53d0a132272c2bb8c69e8ba928f2f267679aee48cec4598faa828788a219dfa342162e1fcf8159bf46b44d50db57180f1aa972edd67fa43e9cd5
+DIST xpra-html5-6.0.tar.gz 1417240 BLAKE2B c887d88c97f4925c511e4120556b98329c205e5fecb8189d615028b4e982d829c9d5649beb646a3f2f0ca42138dd8c26fdb86a2c2c2ee85834e88d14ce8ae1cc SHA512 e5c923df17f25e065ca90499ead4cd33057bf8c2a06aa3b8d4c74e2b3a083b69b525f2dd4d01267168fe5bd8211035067bf952802a64c198dc21106dc7aa384f
EBUILD xpra-html5-5.0.ebuild 949 BLAKE2B dcab443bc7bfbfcc6524a8ab136de1fa9d94c2fd226c71cdaaca4ce57c5e0d5468b1ffb12a6a42a661d4f72756e4cc70b508983173f8fe4bfae2d72e3bfaf8fd SHA512 d4d16e81940d83734814486e616e519eb6084cf5a0207fa423433cb527ebad3f39787621b0e49af58a0c3d750410560b909147558d8f2f90469311ef2196d619
+EBUILD xpra-html5-6.0.ebuild 951 BLAKE2B bc8b0a78200e8d3effbf17ec7a0e32e011f8f5f924ab006f841c5cb1227878f9c8cb7c87fbfd1b28a83d765e938551d948fe05287f2db1fe83a5a51a34f9449f SHA512 f06d8e7491149ab63a3ef5a43cb88072ef59e583a283397e7b1a9bbbdb03914b7bafc10bbd01da05d6d167cbacd6f89310da570acb37083028cb2f4912dad8ea
MISC metadata.xml 551 BLAKE2B 6d62f17a775361ec0b066cb994bc5a6ccc841e61991aa44a72512e82ac94c6a66ad7fbf3998c784cf830cfe44f03e496edd9b491e95f173fea71f328349bd457 SHA512 d839ba317b8d58e5849de92243408096799b1328baa3d46e0ca06e4c038639a35566a9a636f7da491820bc0e3af0cbd5e18043bf815b873f3ead4d68ff54c960
diff --git a/www-apps/xpra-html5/xpra-html5-6.0.ebuild b/www-apps/xpra-html5/xpra-html5-6.0.ebuild
new file mode 100644
index 000000000000..5c2270895f63
--- /dev/null
+++ b/www-apps/xpra-html5/xpra-html5-6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit python-any-r1
+
+DESCRIPTION="HTML5 client to connect to any xpra server"
+HOMEPAGE="https://xpra.org/"
+SRC_URI="https://github.com/Xpra-org/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="brotli +gzip minify"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ brotli? ( app-arch/brotli )
+ minify? ( dev-util/uglifyjs )
+"
+
+src_configure() {
+ cat <<EOF > vcs-info || die
+BRANCH=gentoo
+REVISION=${PR#r}
+LOCAL_MODIFICATIONS=0
+EOF
+}
+
+src_install() {
+ "${PYTHON}" <<EOF || die
+import setup
+setup.set_version("${PV}")
+setup.install_html5(
+ root="${D}",
+ install_dir="${EPREFIX}/usr/share/xpra/www/",
+ config_dir="${EPREFIX}/etc/xpra/html5-client",
+ minifier="$(usex minify uglifyjs copy)",
+ gzip=$(usex gzip True False),
+ brotli=$(usex brotli True False),
+)
+EOF
+}