summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-27 01:25:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-27 01:25:47 +0100
commitabc3bfc07d931f667a0f50cf607f1c8a49af879f (patch)
treee1955376c90c745c2b110a9abf62eb2d5c209a2b /www-apps
parent21dea977c89ba487b57c7856a4924950e667f209 (diff)
gentoo auto-resync : 27:09:2024 - 01:25:47
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/Manifest.gzbin12988 -> 12989 bytes
-rw-r--r--www-apps/rutorrent/Manifest2
-rw-r--r--www-apps/rutorrent/rutorrent-4.3.7.ebuild71
3 files changed, 73 insertions, 0 deletions
diff --git a/www-apps/Manifest.gz b/www-apps/Manifest.gz
index 6a4cbe310204..74486c36873c 100644
--- a/www-apps/Manifest.gz
+++ b/www-apps/Manifest.gz
Binary files differ
diff --git a/www-apps/rutorrent/Manifest b/www-apps/rutorrent/Manifest
index 16bbabec7028..8a23f99d1c39 100644
--- a/www-apps/rutorrent/Manifest
+++ b/www-apps/rutorrent/Manifest
@@ -1,4 +1,6 @@
DIST rutorrent-4.3.6.tar.gz 2377710 BLAKE2B f3bab570ebf7e577d0587ed4fef7e1cb5c40e256f9b4bc6f8cdb603ef516ad6a666ea52314f4c3f6e0ab4991e6027e12e5d6c76320b58747eaf37d0e52e6d6a8 SHA512 bfed8e799b0261f974678f24056070339b443cd24fa53db14585d141e31237c391d51a0bb4675c39930a3288d6cd758524dc77711f7e46e3af0d1df4bbc97917
+DIST rutorrent-4.3.7.tar.gz 2377776 BLAKE2B caa90838d4ac390cdeeafa46dcccf2b3ad955913f0e1b9e00f89912440ab2a6470cc4a73724f8a2b9700dd879c154099a88355bf769dffd5285a7926b36e46a5 SHA512 79d28a20c544dd37303c654d33c3eea88e3aac3a449c8be30c725de60f7253ac10d0f70f3e47528d8734b10cf1b69325da58915d9cad0c29c22c2c70a12a6982
EBUILD rutorrent-4.3.6.ebuild 1823 BLAKE2B 9dc18b75f6832abdda6b903d30944922f5a5e4f100eadc81de128f82e2a68b838729e0bbf9466af1217c82c6d6b9e8e472836abf4c1751e73968e258b0d7c553 SHA512 dbfadca5a4122cf458a862a8578e7f0d3a8a7e7d0a06faafa94d744ec41c2af1a3e6140381990a2ffcf4c93bd3a0c5b59a0fb12219d4a35e63986343175f7b31
+EBUILD rutorrent-4.3.7.ebuild 1823 BLAKE2B 9dc18b75f6832abdda6b903d30944922f5a5e4f100eadc81de128f82e2a68b838729e0bbf9466af1217c82c6d6b9e8e472836abf4c1751e73968e258b0d7c553 SHA512 dbfadca5a4122cf458a862a8578e7f0d3a8a7e7d0a06faafa94d744ec41c2af1a3e6140381990a2ffcf4c93bd3a0c5b59a0fb12219d4a35e63986343175f7b31
EBUILD rutorrent-9999.ebuild 1823 BLAKE2B 3ccbc5bce6c2bed8328f4911409350e50fda8dbe393069b857bc39ebf75368905dab5fdac75c5a2f2ca16b88bc67e801c029e02874182bfd26bb46c747ee0102 SHA512 35fe365ca6478306b9a15f3b24f8a89434b52bf788d53ff308907cb51bf7c2ca04ee0bf84f7c83dc41435b8f5a5d7027295457d77778b66d14742c7828865b9e
MISC metadata.xml 478 BLAKE2B 51373fb574d5353a98f9ae5fc190448d9659fbc6b99a4e631f490b410ebfd9840507d62a08214045350aeb965f834432500412e5ceb146552f02c53141c4cdec SHA512 c253d933bd4cf0edb8516fc0f851f98543a27c422bcd5179d1ca95da28e37df6ea30c27d3685592374103b1af84ca5c98a6ea1060a20267e4485e38f9e54e5d2
diff --git a/www-apps/rutorrent/rutorrent-4.3.7.ebuild b/www-apps/rutorrent/rutorrent-4.3.7.ebuild
new file mode 100644
index 000000000000..97453fadf5c8
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-4.3.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp optfeature
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="https://github.com/Novik/ruTorrent"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Novik/ruTorrent.git"
+else
+ SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ S="${WORKDIR}/ruTorrent-${PV}"
+fi
+
+LICENSE="GPL-2+ MIT"
+
+RDEPEND="
+ dev-lang/php[xml,gd]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ rm -r .github || die
+ find . \( -name .gitignore -o -name .gitmodules \) -type f -delete || die
+ if [[ ${PV} == 9999 ]]; then
+ rm -r .git .gitattributes || die
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # can not use fperms beacuse of globbing
+ chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
+ "${ED}${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ keepdir "${MY_HTDOCSDIR}"/conf/users
+ keepdir "${MY_HTDOCSDIR}"/share/settings
+ keepdir "${MY_HTDOCSDIR}"/share/torrents
+ keepdir "${MY_HTDOCSDIR}"/share/users
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/conf
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/share
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "Show audio file spectogram" media-sound/sox
+ optfeature "Display media file information" media-video/mediainfo
+ optfeature "Scrape Cloudflare based sites" dev-python/cloudscraper
+}