summaryrefslogtreecommitdiff
path: root/www-client/elinks/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-01 02:21:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-01 02:21:02 +0000
commitd682a95de35077b0728025627e082b67339fa249 (patch)
tree39d9937c5811d188bcc3ca56fd3305a42f94fde6 /www-client/elinks/files
parentc4b414ba84991b36b62c066b701385eaf44cdd49 (diff)
gentoo auto-resync : 01:01:2023 - 02:21:02
Diffstat (limited to 'www-client/elinks/files')
-rw-r--r--www-client/elinks/files/elinks-0.16.0-fix-build-mujs.patch47
-rw-r--r--www-client/elinks/files/elinks-0.16.0-fix-tests.patch19
2 files changed, 66 insertions, 0 deletions
diff --git a/www-client/elinks/files/elinks-0.16.0-fix-build-mujs.patch b/www-client/elinks/files/elinks-0.16.0-fix-build-mujs.patch
new file mode 100644
index 000000000000..030280c61f1e
--- /dev/null
+++ b/www-client/elinks/files/elinks-0.16.0-fix-build-mujs.patch
@@ -0,0 +1,47 @@
+https://github.com/rkd77/elinks/issues/204
+https://github.com/rkd77/elinks/pull/205
+
+From 5cb602191830737531f8c715f47f7429959b2471 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sat, 31 Dec 2022 21:06:57 +0000
+Subject: [PATCH] Fix build failures with mujs
+
+Closes: https://github.com/rkd77/elinks/issues/204
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/src/document/html/parser/general.c
++++ b/src/document/html/parser/general.c
+@@ -41,6 +41,9 @@
+ /* Unsafe macros */
+ #include "document/html/internal.h"
+
++#if defined(CONFIG_ECMASCRIPT_SMJS) || defined(CONFIG_QUICKJS) || defined(CONFIG_MUJS)
++#include "ecmascript/ecmascript.h"
++#endif
+
+ void
+ html_span(struct html_context *html_context, char *a,
+--- a/src/document/html/parser/stack.c
++++ b/src/document/html/parser/stack.c
+@@ -27,6 +27,10 @@
+ /* Unsafe macros */
+ #include "document/html/internal.h"
+
++#if defined(CONFIG_ECMASCRIPT_SMJS) || defined(CONFIG_QUICKJS) || defined(CONFIG_MUJS)
++#include "ecmascript/ecmascript.h"
++#endif
++
+ #if 0 //def CONFIG_XML
+ #include <libxml++/libxml++.h>
+ #endif
+--- a/src/ecmascript/ecmascript.h
++++ b/src/ecmascript/ecmascript.h
+@@ -5,6 +5,8 @@
+ /* In the future you will get DOM, a complete ECMAScript interface and free
+ * plasm displays for everyone. */
+
++#include <stdbool.h>
++
+ #ifdef HAVE_CONFIG_H
+ #include "config.h"
+ #endif
+
diff --git a/www-client/elinks/files/elinks-0.16.0-fix-tests.patch b/www-client/elinks/files/elinks-0.16.0-fix-tests.patch
new file mode 100644
index 000000000000..6b46b63afcdd
--- /dev/null
+++ b/www-client/elinks/files/elinks-0.16.0-fix-tests.patch
@@ -0,0 +1,19 @@
+https://github.com/rkd77/elinks/issues/203
+https://github.com/rkd77/elinks/commit/aa8d7989815d48b6afdc3e321bd859f4453bacf2
+
+From aa8d7989815d48b6afdc3e321bd859f4453bacf2 Mon Sep 17 00:00:00 2001
+From: Witold Filipczyk <witekfl@poczta.onet.pl>
+Date: Fri, 30 Dec 2022 09:35:41 +0100
+Subject: [PATCH] [test] Strange endif . Refs #203
+
+--- a/src/dom/test/meson.build
++++ b/src/dom/test/meson.build
+@@ -28,7 +28,6 @@ meson.source_root()+'/src/dom/sgml/xbel/xbel.c',
+ testdeps,
+ c_args:['-DHAVE_CONFIG_H'], cpp_args:['-DHAVE_CONFIG_H'], include_directories:['.', '../..', '../../..'],
+ build_by_default:false)
+-endif
+
+ test_lib = environment({'TEST_LIB': meson.source_root()+'/test/libtest.sh'})
+
+