summaryrefslogtreecommitdiff
path: root/www-client/fetch/fetch-1.0-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /www-client/fetch/fetch-1.0-r4.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'www-client/fetch/fetch-1.0-r4.ebuild')
-rw-r--r--www-client/fetch/fetch-1.0-r4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/www-client/fetch/fetch-1.0-r4.ebuild b/www-client/fetch/fetch-1.0-r4.ebuild
new file mode 100644
index 000000000000..cb11f73398de
--- /dev/null
+++ b/www-client/fetch/fetch-1.0-r4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTTP download tool built atop the HTTP fetcher library"
+HOMEPAGE="https://sourceforge.net/projects/fetch/"
+SRC_URI="mirror://sourceforge/fetch/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/http-fetcher
+ !dev-perl/BTLib"
+
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( docs/fetch.html )
+
+src_prepare() {
+ default
+ sed -i -e "/^ld_rpath/d" configure || die "sed failed"
+}