summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-117.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-30 16:08:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-30 16:08:47 +0100
commite744ca7502c41cb37fe777c783aa029707910f21 (patch)
tree45ddc2a4264632184dca94ab331eed2f6c08191f /www-client/firefox/firefox-117.0.ebuild
parent97b6af3d234a8e2f0a40851cb5701b3172cdbf63 (diff)
gentoo auto-resync : 30:08:2023 - 16:08:46
Diffstat (limited to 'www-client/firefox/firefox-117.0.ebuild')
-rw-r--r--www-client/firefox/firefox-117.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/www-client/firefox/firefox-117.0.ebuild b/www-client/firefox/firefox-117.0.ebuild
index c0dda104858f..2a9718f34585 100644
--- a/www-client/firefox/firefox-117.0.ebuild
+++ b/www-client/firefox/firefox-117.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-FIREFOX_PATCHSET="firefox-117-patches-01.tar.xz"
+FIREFOX_PATCHSET="firefox-117-patches-02.tar.xz"
LLVM_MAX_SLOT=16
@@ -686,6 +686,10 @@ src_prepare() {
find "${S}"/third_party -type f \( -name '*.so' -o -name '*.o' \) -print -delete || die
+ # Clear checksums from cargo crates we've manually patched.
+ # moz_clear_vendor_checksums xyz
+ moz_clear_vendor_checksums proc-macro2
+
# Respect choice for "jumbo-build"
# Changing the value for FILES_PER_UNIFIED_FILE may not work, see #905431
if [[ -n ${FILES_PER_UNIFIED_FILE} ]] && use jumbo-build; then
@@ -740,6 +744,7 @@ src_configure() {
CXX=${CHOST}-clang++-${version_clang}
NM=llvm-nm
RANLIB=llvm-ranlib
+ READELF=llvm-readelf
elif ! use clang && ! tc-is-gcc ; then
# Force gcc
have_switched_compiler=yes
@@ -749,6 +754,7 @@ src_configure() {
CXX=${CHOST}-g++
NM=gcc-nm
RANLIB=gcc-ranlib
+ READELF=readelf
fi
if [[ -n "${have_switched_compiler}" ]] ; then