summaryrefslogtreecommitdiff
path: root/www-client/netsurf/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /www-client/netsurf/files
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'www-client/netsurf/files')
-rw-r--r--www-client/netsurf/files/netsurf-3.10-disable-failing-tests.patch42
-rw-r--r--www-client/netsurf/files/netsurf-3.10-julia-libutf8proc-header-location.patch34
-rw-r--r--www-client/netsurf/files/netsurf-3.6-conditionally-include-image-headers.patch31
-rw-r--r--www-client/netsurf/files/netsurf-3.8-CFLAGS.patch79
-rw-r--r--www-client/netsurf/files/netsurf-3.8-pdf-writer.patch86
5 files changed, 76 insertions, 196 deletions
diff --git a/www-client/netsurf/files/netsurf-3.10-disable-failing-tests.patch b/www-client/netsurf/files/netsurf-3.10-disable-failing-tests.patch
new file mode 100644
index 000000000000..6ffcec002e0b
--- /dev/null
+++ b/www-client/netsurf/files/netsurf-3.10-disable-failing-tests.patch
@@ -0,0 +1,42 @@
+From 4c3d6b10802b6747ba36b6e7c988f6b584352358 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Wed, 17 Jun 2020 17:42:34 -0400
+Subject: [PATCH 1/1] test: disable failing tests.
+
+Just cut them right out of the Makefile if they ain't gonna work.
+
+Bug: https://bugs.gentoo.org/687378
+Upstream-bug: https://bugs.netsurf-browser.org/mantis/view.php?id=2779
+---
+ test/Makefile | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git a/test/Makefile b/test/Makefile
+index 82ffee6..952d238 100644
+--- a/test/Makefile
++++ b/test/Makefile
+@@ -5,8 +5,6 @@ TESTS := \
+ nsurl \
+ urldbtest \
+ nsoption \
+- bloom \
+- hashtable \
+ hashmap \
+ urlescape \
+ utils \
+@@ -47,12 +45,6 @@ messages_SRCS := utils/messages.c utils/hashtable.c test/log.c test/messages.c
+ # nsoption test sources
+ nsoption_SRCS := utils/nsoption.c test/log.c test/nsoption.c
+
+-# Bloom filter test sources
+-bloom_SRCS := utils/bloom.c test/bloom.c
+-
+-# hash table test sources
+-hashtable_SRCS := utils/hashtable.c test/log.c test/hashtable.c
+-
+ # hashmap test sources
+ hashmap_SRCS := $(NSURL_SOURCES) utils/hashmap.c utils/corestrings.c test/log.c test/hashmap.c
+ hashmap_LD := -lmalloc_fig
+--
+2.26.2
+
diff --git a/www-client/netsurf/files/netsurf-3.10-julia-libutf8proc-header-location.patch b/www-client/netsurf/files/netsurf-3.10-julia-libutf8proc-header-location.patch
new file mode 100644
index 000000000000..3a6ccc2466f4
--- /dev/null
+++ b/www-client/netsurf/files/netsurf-3.10-julia-libutf8proc-header-location.patch
@@ -0,0 +1,34 @@
+From d585a1573819306bb3660db3f13a85b2fd254c63 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Wed, 17 Jun 2020 17:23:10 -0400
+Subject: [PATCH 1/1] utils/idna.c: adjust utf8proc.h header location.
+
+There are two upstreams for libutf8proc, and they each put utf8proc.h
+in a different location -- ostensibly as a performance art piece
+intended to remind the programmer that we as human beings are all
+slowly dying, and that our limited time here on earth should not be
+wasted. This commit switches the header location from the netsurf-
+upstream one that used to work, to the julia-upstream location that
+works now (that the Gentoo package follows the julia upstream).
+
+Bug: https://bugs.gentoo.org/721318
+---
+ utils/idna.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/utils/idna.c b/utils/idna.c
+index 628ef1f..f6e498a 100644
+--- a/utils/idna.c
++++ b/utils/idna.c
+@@ -167,7 +167,7 @@ idna__ace_to_ucs4(const char *ace_label,
+
+ #ifdef WITH_UTF8PROC
+
+-#include <libutf8proc/utf8proc.h>
++#include <utf8proc.h>
+
+ int32_t idna_contexto[] = {
+ /* CONTEXTO codepoints which have a rule defined */
+--
+2.26.2
+
diff --git a/www-client/netsurf/files/netsurf-3.6-conditionally-include-image-headers.patch b/www-client/netsurf/files/netsurf-3.6-conditionally-include-image-headers.patch
deleted file mode 100644
index 06754464cb6c..000000000000
--- a/www-client/netsurf/files/netsurf-3.6-conditionally-include-image-headers.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- netsurf-3.6/content/handlers/image/image.c
-+++ netsurf-3.6/content/handlers/image/image.c
-@@ -27,14 +27,28 @@
- #include "netsurf/content.h"
- #include "desktop/gui_internal.h"
-
-+#ifdef WITH_BMP
- #include "image/bmp.h"
-+#endif
-+#ifdef WITH_GIF
- #include "image/gif.h"
-+#endif
- #include "image/ico.h"
-+#ifdef WITH_JPEG
- #include "image/jpeg.h"
-+#endif
-+#ifdef WITH_NSSPRITE
- #include "image/nssprite.h"
-+#endif
-+#ifdef WITH_PNG
- #include "image/png.h"
-+#endif
-+#ifdef WITH_RSVG
- #include "image/rsvg.h"
-+#endif
-+#ifdef WITH_NS_SVG
- #include "image/svg.h"
-+#endif
- #include "image/image.h"
-
- /**
diff --git a/www-client/netsurf/files/netsurf-3.8-CFLAGS.patch b/www-client/netsurf/files/netsurf-3.8-CFLAGS.patch
deleted file mode 100644
index c52422dcb92b..000000000000
--- a/www-client/netsurf/files/netsurf-3.8-CFLAGS.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-diff --git a/Makefile.defaults b/Makefile.defaults
-index 51090109e..f1ec46f73 100644
---- a/Makefile.defaults
-+++ b/Makefile.defaults
-@@ -114,12 +114,6 @@ NETSURF_USE_SANITIZERS := NO
- # But recover after sanitizer failure
- NETSURF_RECOVER_SANITIZERS := YES
-
--# Initial CFLAGS. Optimisation level etc. tend to be target specific.
--CFLAGS :=
--
--# Initial CXXFLAGS. Optimisation level etc. tend to be target specific.
--CXXFLAGS :=
--
- # Default installation/execution prefix
- PREFIX ?= /usr/local
-
-diff --git a/frontends/framebuffer/Makefile b/frontends/framebuffer/Makefile
-index bdedd903b..35179138a 100644
---- a/frontends/framebuffer/Makefile
-+++ b/frontends/framebuffer/Makefile
-@@ -20,7 +20,7 @@ CFLAGS += '-DNETSURF_FB_FONT_MONOSPACE_BOLD="$(NETSURF_FB_FONT_MONOSPACE_BOLD)"'
- CFLAGS += '-DNETSURF_FB_FONT_CURSIVE="$(NETSURF_FB_FONT_CURSIVE)"'
- CFLAGS += '-DNETSURF_FB_FONT_FANTASY="$(NETSURF_FB_FONT_FANTASY)"'
-
--CFLAGS += -std=c99 -g -Dsmall \
-+CFLAGS += -std=c99 -Dsmall \
- -D_BSD_SOURCE \
- -D_DEFAULT_SOURCE \
- -D_XOPEN_SOURCE=600 \
-diff --git a/frontends/framebuffer/Makefile.defaults b/frontends/framebuffer/Makefile.defaults
-index cc712e992..f132c97d6 100644
---- a/frontends/framebuffer/Makefile.defaults
-+++ b/frontends/framebuffer/Makefile.defaults
-@@ -3,7 +3,7 @@
- # ----------------------------------------------------------------------------
-
- # Optimisation levels
--CFLAGS += -O2
-+CFLAGS +=
-
- # Framebuffer default surface provider.
- # Valid values are: x, sdl, linux, vnc, able,
-diff --git a/frontends/gtk/Makefile b/frontends/gtk/Makefile
-index ec60ce70c..04af6df8f 100644
---- a/frontends/gtk/Makefile
-+++ b/frontends/gtk/Makefile
-@@ -33,7 +33,7 @@ GTKDEPFLAGS += -DGTK_DISABLE_DEPRECATED
- endif
-
-
--GTKCFLAGS := -std=c99 -Dgtk -Dnsgtk -g \
-+GTKCFLAGS := -std=c99 -Dgtk -Dnsgtk \
- $(GTKDEPFLAGS) \
- -D_BSD_SOURCE \
- -D_DEFAULT_SOURCE \
-diff --git a/frontends/gtk/Makefile.defaults b/frontends/gtk/Makefile.defaults
-index a98043eb9..bb5371230 100644
---- a/frontends/gtk/Makefile.defaults
-+++ b/frontends/gtk/Makefile.defaults
-@@ -39,4 +39,4 @@ NETSURF_FS_BACKING_STORE := YES
- NETSURF_GTK_MAJOR ?= 2
-
- # Optimisation levels
--CFLAGS += -O2
-+CFLAGS +=
-diff --git a/test/Makefile b/test/Makefile
-index 4f9dd22c9..8bec9b88a 100644
---- a/test/Makefile
-+++ b/test/Makefile
-@@ -134,7 +134,7 @@ ifneq ($(CC_MAJOR),2)
- COMMON_WARNFLAGS += -Wno-unused-parameter
- endif
-
--BASE_TESTCFLAGS := -std=c99 -g \
-+BASE_TESTCFLAGS := -std=c99 \
- $(COMMON_WARNFLAGS) \
- -D_DEFAULT_SOURCE \
- -D_POSIX_C_SOURCE=200809L \
diff --git a/www-client/netsurf/files/netsurf-3.8-pdf-writer.patch b/www-client/netsurf/files/netsurf-3.8-pdf-writer.patch
deleted file mode 100644
index e9c2420a33fd..000000000000
--- a/www-client/netsurf/files/netsurf-3.8-pdf-writer.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-diff --git a/desktop/font_haru.c b/desktop/font_haru.c
-index 4ee9824f0..3304ba82a 100644
---- a/desktop/font_haru.c
-+++ b/desktop/font_haru.c
-@@ -37,7 +37,7 @@
- #include <hpdf.h>
-
- #include "utils/nsoption.h"
--#include "desktop/save_pdf/font_haru.h"
-+#include "desktop/font_haru.h"
- #include "desktop/font.h"
- #include "utils/log.h"
-
-diff --git a/desktop/save_pdf.c b/desktop/save_pdf.c
-index 889190089..9e6265cfb 100644
---- a/desktop/save_pdf.c
-+++ b/desktop/save_pdf.c
-@@ -60,6 +60,8 @@
- #include "utils/useragent.h"
- #include "content/hlcache.h"
- #include "utils/nsoption.h"
-+#include "desktop/gui_misc.h"
-+#include "desktop/gui_internal.h"
- #include "netsurf/bitmap.h"
-
- #include "netsurf/plotters.h"
-@@ -455,11 +457,6 @@ HPDF_Image pdf_extract_image(struct bitmap *bitmap)
-
- switch(content_get_type(content)){
- /*Handle "embeddable" types of images*/
-- case CONTENT_JPEG:
-- image = HPDF_LoadJpegImageFromMem(pdf_doc,
-- (const HPDF_BYTE *) source_data,
-- source_size);
-- break;
-
- /*Disabled until HARU PNG support will be more stable.
-
-@@ -706,7 +703,7 @@ bool pdf_begin(struct print_settings *print_settings)
-
-
- #ifndef PDF_DEBUG
-- if (option_enable_PDF_compression)
-+ if (nsoption_bool(enable_PDF_compression))
- HPDF_SetCompressionMode(pdf_doc, HPDF_COMP_ALL); /*Compression on*/
- #endif
- HPDF_SetInfoAttr(pdf_doc, HPDF_INFO_CREATOR, user_agent_string());
-@@ -780,7 +777,7 @@ void pdf_end(void)
- assert(settings->output != NULL);
-
- /*Encryption on*/
-- if (option_enable_PDF_password)
-+ if (nsoption_bool(enable_PDF_password))
- guit->misc->pdf_password(&owner_pass, &user_pass,
- (void *)settings->output);
- else
-@@ -795,7 +792,7 @@ nserror save_pdf(const char *path)
- {
- nserror res = NSERROR_OK;
-
-- if (option_enable_PDF_password && owner_pass != NULL ) {
-+ if (nsoption_bool(enable_PDF_password) && owner_pass != NULL ) {
- HPDF_SetPassword(pdf_doc, owner_pass, user_pass);
- HPDF_SetEncryptionMode(pdf_doc, HPDF_ENCRYPT_R3, 16);
- free(owner_pass);
-diff --git a/frontends/gtk/scaffolding.c b/frontends/gtk/scaffolding.c
-index 8c46fd884..748518fdc 100644
---- a/frontends/gtk/scaffolding.c
-+++ b/frontends/gtk/scaffolding.c
-@@ -853,14 +853,14 @@ MULTIHANDLER(pdf)
-
- free(url_name);
-
-- strncpy(dirname, option_downloads_directory, PATH_MAX);
-+ strncpy(dirname, nsoption_charp(downloads_directory), PATH_MAX);
- strncat(dirname, "/", PATH_MAX - strlen(dirname));
- dirname[PATH_MAX - 1] = '\0';
-
- /* this way the scale used by PDF functions is synchronised with that
- * used by the all-purpose print interface
- */
-- haru_nsfont_set_scale((float)option_export_scale / 100);
-+ haru_nsfont_set_scale((float)nsoption_int(export_scale) / 100);
-
- save_dialog = gtk_file_chooser_dialog_new("Export to PDF", g->window,
- GTK_FILE_CHOOSER_ACTION_SAVE,