summaryrefslogtreecommitdiff
path: root/www-client/tangram
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /www-client/tangram
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'www-client/tangram')
-rw-r--r--www-client/tangram/Manifest3
-rw-r--r--www-client/tangram/tangram-3.1.ebuild66
2 files changed, 69 insertions, 0 deletions
diff --git a/www-client/tangram/Manifest b/www-client/tangram/Manifest
index b3503345ba57..5b13249e70b6 100644
--- a/www-client/tangram/Manifest
+++ b/www-client/tangram/Manifest
@@ -1,4 +1,7 @@
AUX tangram-2.0-dont-validate-appstream.patch 316 BLAKE2B bf27658b8e818376f3bac3e70e24053d3feb79079bc9dce3564f292950e3c91f8fb645ed8e6c8c5942f8ef6fbebd5229878b641478824e6037897c218c3d783a SHA512 2d05626678c3d193207bda0010f5a907c4eccdc46f71fa23b551dd6363c70c4a25a3e397f31052d620c5f390cbf047fbf626646c95de10808776d16fab24561b
DIST tangram-3.0.tar.xz 1379104 BLAKE2B 8a067daf3df328d98af70e66c270ea4e03a5dc6e0e1693d05439feac8cb34bc0816890164fa83f37a1de409a926d8556a192f980586cb71f15bcecb134b89526 SHA512 68914f9f0c08ab272635ae71f796df1e4c66c919a7718e90714978dc16e434681aa8fb475d33bfaaeba31cdb690975457fa9e97f6d866c323e8585149cee7c7b
+DIST tangram-3.1.tar.gz 367083 BLAKE2B 8a3642712937a2bf98fba3bd6752e50f4e2376e4b508045799f91ba7c138b3c398605b45b3743d7769762b1879e120b903a8a52f503c2358f59c256dbc498e0d SHA512 66fe9f0db624f5cca8933dc06c875b716d654fd9bb1f78fea2ba70f70f3b2de5af56fe3eb50594faeee653f2aeba6d89f31a828df68b31988ba5243fceafe5d6
+DIST troll-63392a57392fb8ed944e859269a3751f649f64ec.tar.gz 471050 BLAKE2B f1108e0aee1956f4a5b7c40167b7791917534b8b58061313e9ef6ae1064af9d99fc4ff9776b0cbbf5e694dfd55175db7194f633259d0937ebf2d193973728e02 SHA512 53f093712dd11cf2cc3e0448561b57873d225653bff937efa6a2e264ad3520b601cd623aa0178508e4a81e4f85c187dfc977f7f75bbd15873fce64b48efdcda8
EBUILD tangram-3.0.ebuild 961 BLAKE2B dc5031d3079b5643c5eb26fc0a655c48d1a6d187bb56eb37326be6a721c1a26613df9b0d1e696435d066252dd26ff888aff32f51d27a17e7d12dec2dc73a7185 SHA512 648bb013f33cb4fcd9938c21e2f5600e12f63ce941558346ec90075596ea98106f47f768ade77384b48d5e97d667aafa83f9ddc916fa6e362b4bb513688dcf0d
+EBUILD tangram-3.1.ebuild 1290 BLAKE2B 02079c4b7da219d6d291f70efdcb80741a90e02a8e5735829bdedd1592984c22e4450a768a071c0cc571ee51336bd12aafe1a408620f5fbd51795efbe0130692 SHA512 73ca5b1c8cfcc792dfa304456e7f39c0c42da15d3402143f9424f7ea3d7752825430cb88ac82a49cb1da58c1ec214c6a7c975f9091427b24ccd21d8db77a60dd
MISC metadata.xml 659 BLAKE2B c4df3b1b2325290fb904862aa2f22313a0d676034276c9225ce131306c836ebef9851edb86656b7126a03dff0a5d1bf567eb78b71810bcbd41225b9a9641e056 SHA512 86ac7e661201b17c52a27f42c3b6f6390e0b3bca6815a1241c30e9225c0129886ed335681d7ffe810edd988e2c11607e37dab4b6db5eceaea054935f5010e3d9
diff --git a/www-client/tangram/tangram-3.1.ebuild b/www-client/tangram/tangram-3.1.ebuild
new file mode 100644
index 000000000000..d2b66e656457
--- /dev/null
+++ b/www-client/tangram/tangram-3.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson xdg
+
+DESCRIPTION="Web browser designed to organize and run Web applications"
+HOMEPAGE="https://apps.gnome.org/app/re.sonny.Tangram/
+ https://github.com/sonnyp/Tangram/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/sonnyp/${PN^}.git"
+else
+ TROLL_COMMIT="63392a57392fb8ed944e859269a3751f649f64ec"
+ SRC_URI="
+ https://github.com/sonnyp/${PN^}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://github.com/sonnyp/troll/archive/${TROLL_COMMIT}.tar.gz
+ -> troll-${TROLL_COMMIT}.tar.gz
+ "
+ S="${WORKDIR}/${P^}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=dev-libs/gjs-1.76.0
+ gui-libs/gtk:4
+ gui-libs/libadwaita:1
+ net-libs/webkit-gtk:6
+"
+BDEPEND="
+ ${RDEPEND}
+ dev-libs/appstream-glib
+ dev-util/blueprint-compiler
+ dev-util/desktop-file-utils
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0-dont-validate-appstream.patch"
+)
+
+DOCS=( README.md TODO.md )
+
+src_prepare() {
+ default
+
+ rm -d "${S}/troll" || die
+ cp -r "${WORKDIR}/troll-${TROLL_COMMIT}" "${S}/troll" || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}