summaryrefslogtreecommitdiff
path: root/www-client/uget/uget-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-02 19:31:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-02 19:31:55 +0000
commit7228e7507f59b8f0982c3a68cc5ba8ea35ce1a76 (patch)
treef7e1474a0d0959d82e90a68fd3b17254284207d8 /www-client/uget/uget-9999.ebuild
parentdd3e3c9214bc18697f6f656e8d645d3218a26d76 (diff)
gentoo auto-resync : 02:03:2023 - 19:31:55
Diffstat (limited to 'www-client/uget/uget-9999.ebuild')
-rw-r--r--www-client/uget/uget-9999.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/www-client/uget/uget-9999.ebuild b/www-client/uget/uget-9999.ebuild
index 107388398e44..bd1d745b7b0e 100644
--- a/www-client/uget/uget-9999.ebuild
+++ b/www-client/uget/uget-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools git-r3 xdg
DESCRIPTION="Download manager using gtk+ and libcurl"
HOMEPAGE="http://www.ugetdm.com"
-EGIT_REPO_URI="git://git.code.sf.net/p/urlget/uget2"
+EGIT_REPO_URI="https://git.code.sf.net/p/urlget/uget2"
LICENSE="LGPL-2.1"
SLOT="0"
@@ -24,16 +24,22 @@ RDEPEND="
dev-libs/libgcrypt:0
)
aria2? ( net-misc/aria2[xmlrpc] )
- appindicator? ( dev-libs/libappindicator:3 )
+ appindicator? ( dev-libs/libayatana-appindicator )
gstreamer? ( media-libs/gstreamer:1.0 )
openssl? ( dev-libs/openssl:= )
- libnotify? ( x11-libs/libnotify )"
+ libnotify? ( x11-libs/libnotify )
+"
DEPEND="${RDEPEND}"
BDEPEND="
dev-util/intltool
virtual/pkgconfig
sys-devel/gettext"
+PATCHES=(
+ # https://github.com/ugetdm/uget/issues/49
+ "${FILESDIR}"/${PN}-2.2.1-ayatana.patch
+)
+
src_prepare() {
default
eautoreconf