summaryrefslogtreecommitdiff
path: root/www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
commit586819755b4dbfdffdc8a725ab7c0f86095b8489 (patch)
treed6790c838cfe9607c996e4913fdf11bad5fdd528 /www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild
parent3f71901f8c228f4de570abed1831ce3ee425343e (diff)
gentoo resync : 15.09.2018
Diffstat (limited to 'www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild')
-rw-r--r--www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild b/www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild
new file mode 100644
index 000000000000..70b563708959
--- /dev/null
+++ b/www-misc/profile-sync-daemon/profile-sync-daemon-5.75.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Symlinks and syncs browser profile dirs to RAM"
+HOMEPAGE="https://wiki.archlinux.org/index.php/Profile-sync-daemon"
+SRC_URI="https://github.com/graysky2/profile-sync-daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd zsh-completion"
+
+RDEPEND="
+ app-shells/bash
+ net-misc/rsync[xattr]
+ systemd? ( sys-apps/systemd )"
+
+PATCHES=(
+ "${FILESDIR}/openrc-path.patch"
+ "${FILESDIR}/bad-substitution-fix.patch"
+)
+
+src_install() {
+ emake DESTDIR="${ED}" \
+ install-openrc-all \
+ $(usex systemd "install-systemd" "")
+
+ if ! use zsh-completion; then
+ rm -r "${ED}/usr/share/zsh" || die
+ fi
+
+ fperms -x /etc/cron.hourly/psd-update
+}
+
+pkg_postinst() {
+ elog "The cronjob is -x by default."
+ elog "You might want to set it +x if you don't use"
+ elog "the systemd provided \"psd-resync.timer\"."
+}