summaryrefslogtreecommitdiff
path: root/www-misc/wsmake/wsmake-0.6.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-misc/wsmake/wsmake-0.6.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'www-misc/wsmake/wsmake-0.6.4.ebuild')
-rw-r--r--www-misc/wsmake/wsmake-0.6.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/www-misc/wsmake/wsmake-0.6.4.ebuild b/www-misc/wsmake/wsmake-0.6.4.ebuild
new file mode 100644
index 000000000000..7299d6dc862b
--- /dev/null
+++ b/www-misc/wsmake/wsmake-0.6.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+DESCRIPTION="Website Pre-processor"
+HOMEPAGE="http://www.wsmake.org/"
+SRC_URI="http://ftp.wsmake.org/pub/wsmake6/stable/wsmake-0.6.4.tar.bz2"
+
+KEYWORDS="x86"
+LICENSE="GPL-2 Artistic"
+SLOT="0"
+IUSE=""
+
+src_unpack () {
+ unpack ${A} && cd "${S}"
+ epatch "${FILESDIR}"/${P}-bv.diff
+ epatch "${FILESDIR}"/${P}-gcc43.patch # 251745
+}
+
+src_compile () {
+ econf || die "econf failed"
+ emake || die "emake failed"
+ cd doc
+ tar -cf examples.tar examples || die
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS COPYING ChangeLog* DEVELOPERS LICENSE NEWS README TODO
+ cd doc
+ dodoc manual.txt examples.tar
+}