summaryrefslogtreecommitdiff
path: root/www-plugins/browserpass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /www-plugins/browserpass
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'www-plugins/browserpass')
-rw-r--r--www-plugins/browserpass/Manifest3
-rw-r--r--www-plugins/browserpass/browserpass-2.0.11.ebuild48
-rw-r--r--www-plugins/browserpass/metadata.xml12
3 files changed, 63 insertions, 0 deletions
diff --git a/www-plugins/browserpass/Manifest b/www-plugins/browserpass/Manifest
new file mode 100644
index 000000000000..bf72e61a0d97
--- /dev/null
+++ b/www-plugins/browserpass/Manifest
@@ -0,0 +1,3 @@
+DIST browserpass-2.0.11.tar.gz 176787 BLAKE2B 271c3cf340ecc78c3358f21bc0e6bbcaf857b4ca39c7b0dcf58b1fcef62ea5df4f48adb4ac0bf7c884853f359fdb9ca00300e2f99efa48a1fdc0ba99ce7bd172 SHA512 baa362b63c1743273f56cb7576f96c29ca365fb217d3016824cdb1ce215e36b7f98fc7c3340a5a34853bde7c25283c84ceda570d149a8119bc54be2f0194034b
+EBUILD browserpass-2.0.11.ebuild 1225 BLAKE2B dc24b26dd3d0ae9e99b1ddb6d2355c4d4642f3a9372f4c4c167dd95a1f97d476d0038b9f737b2ad2d6549aa9f379a24f34c877380892d3a97b22c11952e367e0 SHA512 465b10576f8edf09bc606ba6285fd4d11180a8cbfbfae021a1cb73cea700d7a9abfa420c38e0fab8adfbab0537e1ceecb64b2e3857564348b8a28804e75f4b11
+MISC metadata.xml 363 BLAKE2B 8aa3ed7df03a148ce1d425366aedf96f517c8c8580e03df2040e870130fc77367a1cb67b4b93356f20931288e03d76913642cf0688154b4ba4b7af7cf44a6a7b SHA512 66b9bcae2be1aa69dda2374f2c4c4c02d6c1194dcd7750573323b66d6f266a52ed738a89091582864eaa0a0a494bc6e4a16c5d30008c65634cb9c8a368d917a2
diff --git a/www-plugins/browserpass/browserpass-2.0.11.ebuild b/www-plugins/browserpass/browserpass-2.0.11.ebuild
new file mode 100644
index 000000000000..6abafb5c2130
--- /dev/null
+++ b/www-plugins/browserpass/browserpass-2.0.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/dannyvankooten/browserpass
+
+if [[ ${PV} == 9999 ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="WebExtension host binary for pass, a UNIX password manager"
+HOMEPAGE="https://github.com/dannyvankooten/browserpass"
+LICENSE="MIT"
+SLOT="0"
+RDEPEND="app-crypt/gnupg"
+DEPEND="${RDEPEND}
+ dev-go/twofactor:=
+ dev-go/zglob:="
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_compile() {
+ EGO_PN="${EGO_PN}/cmd/browserpass" golang-build_src_compile
+
+ pushd "src/${EGO_PN}" >/dev/null || die
+ sed -e 's|%%replace%%|'${EPREFIX}'/usr/bin/browserpass|' \
+ -i firefox/host.json chrome/host.json || die
+ popd >/dev/null || die
+}
+
+src_install() {
+ dobin browserpass
+
+ pushd "src/${EGO_PN}" >/dev/null || die
+ insinto /usr/$(get_libdir)/mozilla/native-messaging-hosts
+ newins firefox/host.json com.dannyvankooten.browserpass.json
+
+ insinto /etc/chromium/native-messaging-hosts
+ newins chrome/host.json com.dannyvankooten.browserpass.json
+
+ einstalldocs
+ popd >/dev/null || die
+}
diff --git a/www-plugins/browserpass/metadata.xml b/www-plugins/browserpass/metadata.xml
new file mode 100644
index 000000000000..004ae50f4a5f
--- /dev/null
+++ b/www-plugins/browserpass/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" >
+ <email>lluixhi@gmail.com</email>
+ <name>Aric Belsito</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>