summaryrefslogtreecommitdiff
path: root/www-plugins/chrome-binary-plugins/chrome-binary-plugins-121.0.6167.16_beta.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-18 07:50:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-18 07:50:03 +0000
commitf8730c9e91ed2ce341e231c5adffb5f003f77678 (patch)
treeb4ecbb2994744fab3e10498bf64ef81d01ca550d /www-plugins/chrome-binary-plugins/chrome-binary-plugins-121.0.6167.16_beta.ebuild
parent3e02de9a64a4e3d1f1af271a9da7ff7bbf8d86c8 (diff)
gentoo auto-resync : 18:12:2023 - 07:50:03
Diffstat (limited to 'www-plugins/chrome-binary-plugins/chrome-binary-plugins-121.0.6167.16_beta.ebuild')
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-121.0.6167.16_beta.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-121.0.6167.16_beta.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-121.0.6167.16_beta.ebuild
new file mode 100644
index 000000000000..238a410c5c55
--- /dev/null
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-121.0.6167.16_beta.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2012-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="Binary plugins from Google Chrome for use in Chromium"
+HOMEPAGE="https://www.google.com/chrome"
+
+case ${PV} in
+ *_alpha*)
+ SLOT="unstable"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_alpha}-1
+ ;;
+ *_beta*)
+ SLOT="beta"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_beta}-1
+ ;;
+ *)
+ SLOT="stable"
+ CHROMEDIR="opt/google/chrome"
+ MY_PV=${PV}-1
+ ;;
+esac
+
+KEYWORDS="-* ~amd64"
+
+MY_PN="google-chrome-${SLOT}"
+MY_P="${MY_PN}_${MY_PV}"
+
+SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb"
+
+LICENSE="google-chrome"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ sys-libs/glibc
+"
+
+for x in 0 beta stable unstable; do
+ if [[ ${SLOT} != ${x} ]]; then
+ RDEPEND+=" !${CATEGORY}/${PN}:${x}"
+ fi
+done
+
+S="${WORKDIR}/${CHROMEDIR}"
+QA_PREBUILT="*"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your portage tree before reporting fetch failures."
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/chromium-browser"
+ doins -r WidevineCdm
+}