summaryrefslogtreecommitdiff
path: root/www-plugins/passff-host
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /www-plugins/passff-host
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'www-plugins/passff-host')
-rw-r--r--www-plugins/passff-host/Manifest1
-rw-r--r--www-plugins/passff-host/passff-host-1.2.1-r1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/www-plugins/passff-host/Manifest b/www-plugins/passff-host/Manifest
index 71793df7224c..21b60ccf3b59 100644
--- a/www-plugins/passff-host/Manifest
+++ b/www-plugins/passff-host/Manifest
@@ -1,4 +1,5 @@
DIST passff-host-1.2.1.json 176 BLAKE2B 8eddc19cd0c072d25afff5cfa86a95d960ae7b986727099a04a1d983b887922f9ad77e940a2c80e0838a169afe81fa3f6529a901998bb98a6750ac888a09c264 SHA512 e4a4b90fb5323c6dbec339b9e67a7d546c6d7a95754fe03b3a4d96396c28de1caba3068b4e936ee0ce0997f865c8b5e53a3da1fb34f0123a04c5889302c28911
DIST passff-host-1.2.1.py 3666 BLAKE2B 6a95defc3b1abe91f95e83ab20e9d0e533da2ae0e2153d2b50abf0a77aeb426b6b0a0ed042c00912a434dadbf53a9091fa772df9b9f5c330982a9ab49b891bc8 SHA512 5fe848fe0d6a75b679ee18fd5d32fda963853b91ad382fc19780104d44d1052a7191188946af470722dab883f0318ec38980fc24f052aeb5c54cac98f810ee15
+EBUILD passff-host-1.2.1-r1.ebuild 1548 BLAKE2B a8e37386227ff5dd27cea623dfc2830d20dbfaddf751e8917e2b2f757b55ed131200af764eca28fef5c701b7d19af815b36f78b0e40d8dabdff27e38c3cd38ae SHA512 b618615c1ebe17515629941210979ba6a19120a30d8a62d213cbaf0df39cf745d31879bf608e0a7d3817f1663f365d22d037c84fc5d66553fc9fdc98181ce5ff
EBUILD passff-host-1.2.1.ebuild 1410 BLAKE2B 163e51c6a14842b93529553365284a9df20cb8573a686b7dc57a41609f3ad1d1e19c48136c5535af7780dc860df5cd5bb66545ee10696b8b388cd046ceea6fd9 SHA512 3f332d8cdca2a634d8cb05233f8426381d44bce16ea8e3a8d9cccb33c64715f0d1f6e483dc755da863084c38b10f434a61f3d15c484d1c79f74b9aff4cd945a6
MISC metadata.xml 605 BLAKE2B 05c6663ff28370ff663a4213b5a913778a58009f78ab348b5984ddc970af6f3f48622ea2a5c23b45a1a6100ca3d978e2eccbaa2707116e73f41d6ecc179b6d83 SHA512 8572806b39f10ca0598c5a317b059c83b551424830ce5a7fe29b926175dda5f456ccb9297b5cca1d8ab82fed74e4011cc8e674b209f2a00ba7b4df5bbca01906
diff --git a/www-plugins/passff-host/passff-host-1.2.1-r1.ebuild b/www-plugins/passff-host/passff-host-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..ae62d7aaca1c
--- /dev/null
+++ b/www-plugins/passff-host/passff-host-1.2.1-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Host app for the PassFF WebExtension"
+HOMEPAGE="https://github.com/passff/passff-host"
+
+SRC_URI="
+ https://github.com/passff/passff-host/releases/download/${PV}/passff.py -> ${P}.py
+ https://github.com/passff/passff-host/releases/download/${PV}/passff.json -> ${P}.json
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="chrome chromium firefox vivaldi"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( chrome chromium firefox vivaldi )
+"
+
+RDEPEND="${PYTHON_DEPS}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${P}.json" . || die
+ cp "${DISTDIR}/${P}.py" . || die
+}
+
+src_prepare() {
+ default
+ python_fix_shebang "${P}.py"
+}
+
+src_install() {
+ local target_dirs=()
+
+ use chrome && target_dirs+=( "/etc/opt/chrome/native-messaging-hosts" )
+ use chromium && target_dirs+=( "/etc/chromium/native-messaging-hosts" )
+ use firefox && target_dirs+=( "/usr/$(get_libdir)/mozilla/native-messaging-hosts" )
+ # www-client/firefox-bin compile-time dir is under /usr/lib/
+ use firefox && target_dirs+=( "/usr/lib/mozilla/native-messaging-hosts" )
+ use vivaldi && target_dirs+=( "/etc/vivaldi/native-messaging-hosts" )
+
+ for target_dir in "${target_dirs[@]}"; do
+ sed "s;PLACEHOLDER;${target_dir}/passff.py;g" "${P}.json" > "passff.json" || die
+
+ insinto "${target_dir}"
+ doins passff.json
+ exeinto "${target_dir}"
+ newexe "${P}.py" passff.py
+ done
+}