summaryrefslogtreecommitdiff
path: root/www-plugins/pdfjs/pdfjs-2.5.207.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /www-plugins/pdfjs/pdfjs-2.5.207.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'www-plugins/pdfjs/pdfjs-2.5.207.ebuild')
-rw-r--r--www-plugins/pdfjs/pdfjs-2.5.207.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/www-plugins/pdfjs/pdfjs-2.5.207.ebuild b/www-plugins/pdfjs/pdfjs-2.5.207.ebuild
new file mode 100644
index 000000000000..8846fc13803f
--- /dev/null
+++ b/www-plugins/pdfjs/pdfjs-2.5.207.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A PDF reader in JavaScript"
+HOMEPAGE="https://mozilla.github.io/pdf.js/"
+SRC_URI="https://github.com/mozilla/pdf.js/releases/download/v${PV}/${P}-dist.zip -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/pdf.js/
+
+ doins -r build
+ doins -r web
+}