summaryrefslogtreecommitdiff
path: root/www-plugins/pdfjs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-plugins/pdfjs
reinit the tree, so we can have metadata
Diffstat (limited to 'www-plugins/pdfjs')
-rw-r--r--www-plugins/pdfjs/Manifest3
-rw-r--r--www-plugins/pdfjs/metadata.xml15
-rw-r--r--www-plugins/pdfjs/pdfjs-1.9.426.ebuild23
3 files changed, 41 insertions, 0 deletions
diff --git a/www-plugins/pdfjs/Manifest b/www-plugins/pdfjs/Manifest
new file mode 100644
index 000000000000..e806d3232bd4
--- /dev/null
+++ b/www-plugins/pdfjs/Manifest
@@ -0,0 +1,3 @@
+DIST pdfjs-1.9.426.zip 3510568 SHA256 00998c3b731382106e1f3a48ab15dce6714015573f76027c6b178fccf99f286c SHA512 4c6a7ac613755a73d694a80ccea0d0d3d100fb0c7039ae5d866059d39e58b650092a733c7bea6d302cfa196f439d28f59055443ab96443161d1770462d8976ef WHIRLPOOL 6b0b769e8cfff9c82a37e03ff06d5f9d6b5601c8ce25a5db2e10c7a34fc9fe23710d15b209346aea33221248eaa42bd6e554e8f290b0cc0b8157230800264ae2
+EBUILD pdfjs-1.9.426.ebuild 469 SHA256 6f43e577361ce04c5c7723242d35635aab9feb0680b965f339b1ed0b02eb16f5 SHA512 a98b00702b27b64796a533ccf08689848fa32694e3e1811b449b23c303c1f92591ebc2ceb06e0a0052c0d9e5dbe60f655e64c6db61c92eec7461489ee3868de8 WHIRLPOOL 4d6014e08b2a70a8073fa840ba9fe70d6ab5808af7634e98df3267623507ba1b5356ad8c1f857dc80da026973a3280ffa7b7aac16d74c3f8c79e8ca87dd51db0
+MISC metadata.xml 462 SHA256 886ea6848012a4a31526dbd8250d7adfc972e82fca8e6319a44c66643930a8ad SHA512 e82f3171eb5eadbcd71b2804a341a193afe69c8bbec9bf5399b5321a92bf543aa938bfa94e89e84a9d2514211608f02ff91a3461f647f623ca6430c7c427895f WHIRLPOOL 9c15014ddb49efeeef371dd9312a49b1648f2f9aeec3ae62937ec00585d832667e370018a2e77e1583074d3b3f42a3f656bfd5390dd03207083cb0af1892425e
diff --git a/www-plugins/pdfjs/metadata.xml b/www-plugins/pdfjs/metadata.xml
new file mode 100644
index 000000000000..1ce0d7605336
--- /dev/null
+++ b/www-plugins/pdfjs/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hilobakho@gmail.com</email>
+ <name>Mykyta Holubakha</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mozilla/pdf.js</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-plugins/pdfjs/pdfjs-1.9.426.ebuild b/www-plugins/pdfjs/pdfjs-1.9.426.ebuild
new file mode 100644
index 000000000000..4c12535dad2d
--- /dev/null
+++ b/www-plugins/pdfjs/pdfjs-1.9.426.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A PDF reader in JavaScript"
+HOMEPAGE="http://mozilla.github.io/pdf.js/"
+SRC_URI="https://github.com/mozilla/pdf.js/releases/download/v${PV}/${P}-dist.zip -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/pdf.js/
+
+ doins -r build
+ doins -r web
+}