summaryrefslogtreecommitdiff
path: root/www-servers/gunicorn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /www-servers/gunicorn
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'www-servers/gunicorn')
-rw-r--r--www-servers/gunicorn/Manifest1
-rw-r--r--www-servers/gunicorn/gunicorn-20.1.0-r1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/www-servers/gunicorn/Manifest b/www-servers/gunicorn/Manifest
index eb479ce40a75..b12ff72c7b51 100644
--- a/www-servers/gunicorn/Manifest
+++ b/www-servers/gunicorn/Manifest
@@ -1,5 +1,6 @@
AUX gunicorn-20.1.0-new-eventlet.patch 1103 BLAKE2B 3329864c05238c3b2a6e38727991f7273bb0fe5aa8e3e4c09cd2f7132b5d47fb9ee02fde171abbfc64d84ab0bf11b6712101e8510935d284175ea46771bc8f5b SHA512 cf404efa930c1e6948a8d2508107315d380bbd55a54df1e2a2e8472bbf392383a8505cc7dc15077f1d182f7be9ece558676470a6dbedbfcb0d873438b82fa9b8
AUX gunicorn-20.1.0-tests_optional_modules.patch 622 BLAKE2B 27efd7afd2c69e65622091f9fbc59e5db1efbd519015c51cc607735cb6c709b2234e3ee5fce045f3d2c3eb67099b68ae5295d7000df893775e3a28c050b5b0ce SHA512 42ef99e0ae1b125e379cd2d6ef3dd917de640db96411495eaa04c09eae88254fa7930f00de72571aca3320454eef2fdd54d16c97bb09b45abd7232965e4fb861
DIST gunicorn-20.1.0.tar.gz 354960 BLAKE2B bae414a8da7a4dbdf79e0b46f517138534521a1a8544f4ea2e1e27e6778d2f6ad8d6a8af02590fedad47d305acdea53f1cdbc4deeda3619fc4a5ffef0932bea1 SHA512 4fd905f62adc30e044cf2a56a1a77e14bc633258267d6bfbd4f6a68494f93f377e9fb9ed94fab7f11f9d7813857a680974a88c4b6bf97d4f1b74792a81810111
+EBUILD gunicorn-20.1.0-r1.ebuild 1377 BLAKE2B f6d1c8052ead2295d1e10ec9a17cb3e21abd1ab1ff80b31ff14c2f6bb82b1da3c0bc7b477a86240d3b86c5505a7a6348b938e58cbb21cf95db407215f9919069 SHA512 6f2578376e402522776b9f9cb223d8abfc429f4b9ed78ce45725baf6ae5be95eb4a02a8415145861db4207c8d5a3fc56036ac67d1215cc18f3caa39efb61d9dc
EBUILD gunicorn-20.1.0.ebuild 1491 BLAKE2B 4355e0d37670b335a42a5a6ad1a950666996007e0edbe89cf9b35a229ab82437cc23572d049ab5cdb0f3a45fdf9859b6cde584352465fa08531a3a325cf95dea SHA512 802c5a707b6cb3096a092e1d51d110eb12b42455a654839cf387da5bbd158ee77ea96342e05aca3572009a98cdd8121969e3bc7848342873194bbaeb7cb8cb62
MISC metadata.xml 821 BLAKE2B aa75468eafd9c717f3b3b55b4c91917cd94e612f591e752c93bec95b57e5abd4f46fd98de88c52ca5c624dc00f6d45afbd03f04743f962f87be9321902142712 SHA512 c7746b7036159f99a67dcc688a839ec06adf85d2bfb2214a2ec0b961bfcbd9a72fb5f2dd66dc3868f0d50e5d99386e4a4251f872afd7ad932dc4cca6fc33dff3
diff --git a/www-servers/gunicorn/gunicorn-20.1.0-r1.ebuild b/www-servers/gunicorn/gunicorn-20.1.0-r1.ebuild
new file mode 100644
index 000000000000..8bc4d05051cf
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-20.1.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A WSGI HTTP Server for UNIX"
+HOMEPAGE="
+ https://gunicorn.org/
+ https://github.com/benoitc/gunicorn/
+ https://pypi.org/project/gunicorn/
+"
+SRC_URI="
+ https://github.com/benoitc/gunicorn/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT PSF-2 doc? ( BSD )"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.1.0-tests_optional_modules.patch
+ "${FILESDIR}"/${P}-new-eventlet.patch
+)
+
+DOCS=( README.rst )
+
+distutils_enable_sphinx 'docs/source' --no-autodoc
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--cov=gunicorn --cov-report=xml::' -i setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/source/_build/html/. )
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature_header "Alternative worker types need additional packages to be installed:"
+ optfeature "eventlet-based greenlets workers" "dev-python/eventlet"
+ optfeature "gevent-based greenlets workers" "dev-python/gevent"
+}