summaryrefslogtreecommitdiff
path: root/www-servers/tomcat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-12 17:42:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-12 17:42:09 +0100
commit12d78242dec4f785d0a0bfb1c00eee2d8996c53b (patch)
tree0e7146574ec8dc5e4e1ebe328c68a50a48f170ca /www-servers/tomcat
parent6e0dec7ba4f6c5793a3d0b85952efa7ec57afa65 (diff)
gentoo resync : 12.10.2017 (fix rsync script)
Diffstat (limited to 'www-servers/tomcat')
-rw-r--r--www-servers/tomcat/files/tomcat-9.0.0_alpha26-build.xml.patch250
-rw-r--r--www-servers/tomcat/tomcat-9.0.0_alpha26.ebuild158
2 files changed, 0 insertions, 408 deletions
diff --git a/www-servers/tomcat/files/tomcat-9.0.0_alpha26-build.xml.patch b/www-servers/tomcat/files/tomcat-9.0.0_alpha26-build.xml.patch
deleted file mode 100644
index 3c4e5c2a9d45..000000000000
--- a/www-servers/tomcat/files/tomcat-9.0.0_alpha26-build.xml.patch
+++ /dev/null
@@ -1,250 +0,0 @@
-diff --git a/apache-tomcat-9.0.0.M8-src/build.xml b/apache-tomcat-9.0.0.M8-src/build.xml
-index dfec1f7..4dfc5d8 100644
---- a/apache-tomcat-9.0.0.M8-src/build.xml
-+++ b/apache-tomcat-9.0.0.M8-src/build.xml
-@@ -695,24 +695,30 @@
- manifest="${tomcat.manifests}/annotations-api.jar.manifest" />
-
- <!-- Servlet 4.0 Implementation JAR File -->
-+<!--
- <jarIt jarfile="${servlet-api.jar}"
- filesDir="${tomcat.classes}"
- filesId="files.servlet-api"
- manifest="${tomcat.manifests}/servlet-api.jar.manifest"
- notice="${tomcat.manifests}/servlet-api.jar.notice"
- license="${tomcat.manifests}/servlet-api.jar.license" />
-+-->
-
- <!-- JSP 2.3 Implementation JAR File -->
-+<!--
- <jarIt jarfile="${jsp-api.jar}"
- filesDir="${tomcat.classes}"
- filesId="files.jsp-api"
- manifest="${tomcat.manifests}/jsp-api.jar.manifest" />
-+-->
-
- <!-- EL 3.0 Implementation JAR File -->
-+<!--
- <jarIt jarfile="${el-api.jar}"
- filesDir="${tomcat.classes}"
- filesId="files.el-api"
- manifest="${tomcat.manifests}/el-api.jar.manifest" />
-+-->
-
- <!-- WebSocket 1.1 API JAR File -->
- <jarIt jarfile="${websocket-api.jar}"
-@@ -986,14 +992,14 @@
-
- <target name="deploy" depends="package,build-docs,build-tomcat-jdbc,compile-webapp-examples"
- description="Default. Builds a working Tomcat instance">
--
-+<!--
- <copy tofile="${tomcat.build}/bin/tomcat-native.tar.gz"
- file="${tomcat-native.tar.gz}" />
- <copy tofile="${tomcat.build}/bin/commons-daemon-native.tar.gz"
- file="${commons-daemon.native.src.tgz}" />
-
- <copy tofile="${tomcat.build}/bin/commons-daemon.jar" file="${commons-daemon.jar}" />
--
-+-->
- <!-- Copy scripts -->
- <copy todir="${tomcat.build}/bin">
- <fileset dir="bin">
-@@ -1053,7 +1059,7 @@
- <exclude name="${jdt.jar.filename}"/>
- </fileset>
- </delete>
-- <copy file="${jdt.jar}" todir="${tomcat.build}/lib"/>
-+<!-- <copy file="${jdt.jar}" todir="${tomcat.build}/lib"/> -->
-
- <!-- Add sources for examples -->
- <antcall target="examples-sources" />
-@@ -1087,7 +1093,7 @@
- </javac>
- </target>
-
-- <target name="build-tomcat-jdbc" depends="package">
-+ <target name="build-tomcat-jdbc" depends="package" unless="noget">
- <!-- build the jdbc-pool jar and source jar-->
- <echo message="Building Tomcat JDBC pool libraries"/>
- <ant antfile="${tomcat.jdbc.dir}/build.xml" dir="${tomcat.jdbc.dir}"
-@@ -1102,7 +1108,7 @@
- <copy file="${tomcat-jdbc.jar}" todir="${tomcat.build}/lib"/>
- </target>
-
-- <target name="build-tomcat-jdbc-src">
-+ <target name="build-tomcat-jdbc-src" unless="noget">
- <!-- build the jdbc-pool source jar-->
- <echo message="Building Tomcat JDBC pool src JAR"/>
- <ant antfile="${tomcat.jdbc.dir}/build.xml" dir="${tomcat.jdbc.dir}"
-@@ -1206,10 +1212,11 @@
-
- <copy file="${basedir}/LICENSE" todir="${tomcat.embed}" />
- <copy file="${basedir}/NOTICE" todir="${tomcat.embed}" />
-+<!--
- <copy file="${tomcat-dbcp.jar}" todir="${tomcat.embed}"
- failonerror="false"/>
- <copy file="${jdt.jar}" todir="${tomcat.embed}" />
--
-+-->
- <!-- Note the meta-inf below will work as long as there is only one JAR
- that needs to add entries. If there is more than one a more complex
- solution will be required. -->
-@@ -1583,7 +1590,7 @@
-
- <target name="extras-webservices-prepare"
- depends="extras-prepare"
-- description="Prepare to build web services extras package">
-+ description="Prepare to build web services extras package" unless="noget">
-
- <antcall target="downloadfile">
- <param name="sourcefile" value="${jaxrpc-lib.loc}"/>
-@@ -1731,6 +1738,7 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
-
- <target name="javadoc" depends="dist-source,extras-webservices-prepare"
- description="Create the Tomcat javadoc" >
-+<!--
- <javadoc packagenames="javax.servlet.*"
- excludepackagenames="javax.servlet.jsp.*"
- sourcepath="${tomcat.dist}/src/java"
-@@ -1795,6 +1803,7 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
- <path location="${ant.core.lib}"/>
- </classpath>
- </javadoc>
-+-->
- <javadoc packagenames="javax.websocket.*"
- sourcepath="${tomcat.dist}/src/java"
- destdir="${tomcat.dist}/webapps/docs/websocketapi"
-@@ -1835,9 +1844,11 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
- <path refid="tomcat.webservices.classpath"/>
- <path location="${ant.core.lib}"/>
- </classpath>
-+<!--
- <link href="../servletapi"/>
- <link href="../jspapi"/>
- <link href="../elapi"/>
-+-->
- <link href="../websocketapi"/>
- <link href="http://docs.oracle.com/javase/7/docs/api/"/>
- <link href="http://commons.apache.org/proper/commons-io/javadocs/api-release/"/>
-@@ -2578,7 +2589,7 @@ skip.installer property in build.properties" />
- </target>
-
- <target name="download-compile"
-- description="Download (and build) components necessary to compile" >
-+ description="Download (and build) components necessary to compile" unless="noget">
-
- <antcall target="downloadfile-2">
- <param name="sourcefile.1" value="${tomcat-native.loc.1}"/>
-@@ -2612,7 +2623,7 @@ skip.installer property in build.properties" />
- </target>
-
- <target name="download-test-compile"
-- description="Download additional components for the tests" >
-+ description="Download additional components for the tests" unless="noget">
-
- <antcall target="downloadfile">
- <param name="sourcefile" value="${junit.loc}"/>
-@@ -2669,7 +2680,7 @@ skip.installer property in build.properties" />
- </target>
-
- <target name="download-dist"
-- description="Download additional components for a distribution" >
-+ description="Download additional components for a distribution" unless="noget">
-
- <antcall target="downloadzip-2">
- <param name="sourcefile.1" value="${tomcat-native.win.1}"/>
-@@ -2695,18 +2706,18 @@ skip.installer property in build.properties" />
-
- <!-- =============== Utility Targets to support downloads ================ -->
-
-- <target name="setproxy" if="${proxy.use}">
-+ <target name="setproxy" if="${proxy.use}" unless="noget">
- <setproxy proxyhost="${proxy.host}" proxyport="${proxy.port}"
- proxyuser="${proxy.user}" proxypassword="${proxy.password}" />
- <echo message="Using ${proxy.host}:${proxy.port} to download ${sourcefile}"/>
- </target>
-
-- <target name="testexist">
-+ <target name="testexist" unless="noget">
- <echo message="Testing for ${destfile}"/>
- <available file="${destfile}" property="exist"/>
- </target>
-
-- <target name="downloadgz" unless="exist" depends="testexist,setproxy">
-+ <target name="downloadgz" unless="noget" depends="testexist,setproxy">
- <!-- Download and extract the package -->
- <local name="temp.file"/>
- <mkdir dir="${base.path}"/>
-@@ -2718,7 +2729,7 @@ skip.installer property in build.properties" />
- <delete file="${temp.file}.tar.gz"/>
- </target>
-
-- <target name="downloadgz-2" unless="exist" depends="testexist">
-+ <target name="downloadgz-2" unless="noget" depends="testexist">
- <!-- Download and extract the package from the two alternative locations -->
- <local name="temp.file"/>
- <mkdir dir="${base.path}"/>
-@@ -2737,7 +2748,7 @@ skip.installer property in build.properties" />
- <delete file="${temp.file}.tar.gz"/>
- </target>
-
-- <target name="downloadzip" unless="exist" depends="testexist,setproxy">
-+ <target name="downloadzip" unless="noget" depends="testexist,setproxy">
- <!-- Download and extract the package -->
- <local name="temp.file"/>
- <mkdir dir="${base.path}"/>
-@@ -2748,7 +2759,7 @@ skip.installer property in build.properties" />
- <delete file="${temp.file}"/>
- </target>
-
-- <target name="downloadzip-2" unless="exist" depends="testexist">
-+ <target name="downloadzip-2" unless="noget" depends="testexist">
- <!-- Download and extract the package from the two alternative locations -->
- <local name="temp.file"/>
- <mkdir dir="${base.path}"/>
-@@ -2766,7 +2777,7 @@ skip.installer property in build.properties" />
- <delete file="${temp.file}"/>
- </target>
-
-- <target name="downloadfile" unless="exist" depends="testexist,setproxy">
-+ <target name="downloadfile" unless="noget" depends="testexist,setproxy">
- <!-- Download the file -->
- <local name="temp.file"/>
- <mkdir dir="${base.path}"/>
-@@ -2776,7 +2787,7 @@ skip.installer property in build.properties" />
- <move file="${temp.file}" tofile="${destfile}"/>
- </target>
-
-- <target name="downloadfile-2" unless="exist" depends="testexist">
-+ <target name="downloadfile-2" unless="noget" depends="testexist">
- <!-- Download the file from the two alternative locations -->
- <local name="temp.file"/>
- <mkdir dir="${base.path}"/>
-@@ -2799,7 +2810,7 @@ skip.installer property in build.properties" />
- <move file="${temp.file}" tofile="${destfile}"/>
- </target>
-
-- <target name="trydownload.check" depends="setproxy">
-+ <target name="trydownload.check" depends="setproxy" unless="noget">
- <condition property="trydownload.run">
- <and>
- <not>
-@@ -2810,7 +2821,7 @@ skip.installer property in build.properties" />
- </condition>
- </target>
-
-- <target name="trydownload" if="trydownload.run" depends="trydownload.check">
-+ <target name="trydownload" if="trydownload.run" depends="trydownload.check" unless="noget">
- <!-- Downloads a file if not yet downloaded and the source URL is available -->
- <get src="${sourcefile}" httpusecaches="${trydownload.httpusecaches}" dest="${destfile}" />
- </target>
-@@ -2821,7 +2832,7 @@ skip.installer property in build.properties" />
-
- <target name="ide-eclipse"
- depends="download-compile, extras-webservices-prepare, download-test-compile"
-- description="Prepares the source tree to be built in Eclipse">
-+ description="Prepares the source tree to be built in Eclipse" unless="noget">
-
- <!-- Copy the sample project files into the root directory -->
- <copy file="${tomcat.home}/res/ide-support/eclipse/eclipse.project" tofile="${tomcat.home}/.project"/>
diff --git a/www-servers/tomcat/tomcat-9.0.0_alpha26.ebuild b/www-servers/tomcat/tomcat-9.0.0_alpha26.ebuild
deleted file mode 100644
index 8090b4f5c011..000000000000
--- a/www-servers/tomcat/tomcat-9.0.0_alpha26.ebuild
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit eutils java-pkg-2 java-ant-2 prefix user
-
-MY_PV="${PV/_alpha/.M}"
-MY_P="apache-${PN}-${MY_PV}-src"
-
-DESCRIPTION="Tomcat Servlet-4.0/JSP-2.4?/EL-3.1?/WebSocket-1.2?/JASPIC-1.1 Container"
-HOMEPAGE="http://tomcat.apache.org/"
-SRC_URI="mirror://apache/${PN}/tomcat-9/v${MY_PV}/src/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="9"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="extra-webapps"
-
-RESTRICT="test" # can we run them on a production system?
-
-ECJ_SLOT="4.5"
-SAPI_SLOT="4.0"
-
-COMMON_DEP="dev-java/eclipse-ecj:${ECJ_SLOT}
- =dev-java/tomcat-servlet-api-${PV}:${SAPI_SLOT}"
-RDEPEND="${COMMON_DEP}
- !<dev-java/tomcat-native-1.1.24
- >=virtual/jre-1.8"
-DEPEND="${COMMON_DEP}
- app-admin/pwgen
- >=virtual/jdk-1.8
- test? (
- >=dev-java/ant-junit-1.9:0
- dev-java/easymock:3.2
- )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- java-pkg-2_pkg_setup
- enewgroup tomcat 265
- enewuser tomcat 265 -1 /dev/null tomcat
-}
-
-src_prepare() {
- default
-
- find -name '*.jar' -type f -delete -print || die
-
- # Remove bundled servlet-api
- rm -rv java/javax/{el,servlet} || die
-
- epatch "${FILESDIR}/${P}-build.xml.patch"
-
- # For use of catalina.sh in netbeans
- sed -i -e "/^# ----- Execute The Requested Command/ a\
- CLASSPATH=\`java-config --classpath ${PN}-${SLOT}\`" \
- bin/catalina.sh || die
-
- java-pkg-2_src_prepare
-}
-
-JAVA_ANT_REWRITE_CLASSPATH="true"
-
-EANT_BUILD_TARGET="deploy"
-EANT_GENTOO_CLASSPATH="eclipse-ecj-${ECJ_SLOT},tomcat-servlet-api-${SAPI_SLOT}"
-EANT_TEST_GENTOO_CLASSPATH="easymock-3.2"
-EANT_GENTOO_CLASSPATH_EXTRA="${S}/output/classes"
-EANT_NEEDS_TOOLS="true"
-EANT_EXTRA_ARGS="-Dversion=${PV}-gentoo -Dversion.number=${PV} -Dcompile.debug=false"
-
-# revisions of the scripts
-IM_REV="-r2"
-INIT_REV="-r1"
-
-src_compile() {
- EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjar --build-only ant-core ant.jar)"
- java-pkg-2_src_compile
-}
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- local dest="/usr/share/${PN}-${SLOT}"
-
- java-pkg_jarinto "${dest}"/bin
- java-pkg_dojar output/build/bin/*.jar
- exeinto "${dest}"/bin
- doexe output/build/bin/*.sh
-
- java-pkg_jarinto "${dest}"/lib
- java-pkg_dojar output/build/lib/*.jar
-
- dodoc RELEASE-NOTES RUNNING.txt
- use doc && java-pkg_dojavadoc output/dist/webapps/docs/api
- use source && java-pkg_dosrc java/*
-
- ### Webapps ###
-
- # add missing docBase
- local apps="host-manager manager"
- for app in ${apps}; do
- sed -i -e "s|=\"true\" >|=\"true\" docBase=\"\$\{catalina.home\}/webapps/${app}\" >|" \
- output/build/webapps/${app}/META-INF/context.xml || die
- done
-
- insinto "${dest}"/webapps
- doins -r output/build/webapps/{host-manager,manager,ROOT}
- use extra-webapps && doins -r output/build/webapps/{docs,examples}
-
- ### Config ###
-
- # create "logs" directory in $CATALINA_BASE
- # and set correct perms, see #458890
- dodir "${dest}"/logs
- fperms 0750 "${dest}"/logs
-
- # replace the default pw with a random one, see #92281
- local randpw="$(pwgen -s -B 15 1)"
- sed -i -e "s|SHUTDOWN|${randpw}|" output/build/conf/server.xml || die
-
- # prepend gentoo.classpath to common.loader, see #453212
- sed -i -e 's/^common\.loader=/\0${gentoo.classpath},/' output/build/conf/catalina.properties || die
-
- insinto "${dest}"
- doins -r output/build/conf
-
- ### rc ###
-
- cp "${FILESDIR}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash} "${T}" || die
- eprefixify "${T}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash}
- sed -i -e "s|@SLOT@|${SLOT}|g" "${T}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash} || die
-
- insinto "${dest}"/gentoo
- doins "${T}"/tomcat.conf
- exeinto "${dest}"/gentoo
- newexe "${T}"/tomcat${INIT_REV}.init tomcat.init
- newexe "${T}"/tomcat-instance-manager${IM_REV}.bash tomcat-instance-manager.bash
-}
-
-pkg_postinst() {
- elog "New ebuilds of Tomcat support running multiple instances. If you used prior version"
- elog "of Tomcat (<7.0.32), you have to migrate your existing instance to work with new Tomcat."
- elog "You can find more information at https://wiki.gentoo.org/wiki/Apache_Tomcat"
-
- elog "To manage Tomcat instances, run:"
- elog " ${EPREFIX}/usr/share/${PN}-${SLOT}/gentoo/tomcat-instance-manager.bash --help"
-
- ewarn "tomcat-dbcp.jar is not built at this time. Please fetch jar"
- ewarn "from upstream binary if you need it. Gentoo Bug # 144276"
-
-# einfo "Please read https://www.gentoo.org/proj/en/java/tomcat6-guide.xml for more information."
-}