summaryrefslogtreecommitdiff
path: root/www-servers/tornado/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-servers/tornado/files
reinit the tree, so we can have metadata
Diffstat (limited to 'www-servers/tornado/files')
-rw-r--r--www-servers/tornado/files/4.4-drop-intersphinx.patch36
-rw-r--r--www-servers/tornado/files/4.4.1-options-test.patch13
-rw-r--r--www-servers/tornado/files/4.5.1-drop-intersphinx.patch22
3 files changed, 71 insertions, 0 deletions
diff --git a/www-servers/tornado/files/4.4-drop-intersphinx.patch b/www-servers/tornado/files/4.4-drop-intersphinx.patch
new file mode 100644
index 000000000000..cec403e772fb
--- /dev/null
+++ b/www-servers/tornado/files/4.4-drop-intersphinx.patch
@@ -0,0 +1,36 @@
+diff --git a/docs/Makefile b/docs/Makefile
+index 7001b80..ab2ffdd 100644
+--- a/docs/Makefile
++++ b/docs/Makefile
+@@ -3,7 +3,7 @@ all: sphinx
+
+ # No -W for doctests because that disallows tests with empty output.
+ SPHINX_DOCTEST_OPTS=-n -d build/doctress .
+-SPHINXOPTS=-n -W -d build/doctrees .
++SPHINXOPTS=-n -d build/doctrees .
+
+ .PHONY: sphinx
+ sphinx:
+diff --git a/docs/conf.py b/docs/conf.py
+index 368e4e8..85a276d 100644
+--- a/docs/conf.py
++++ b/docs/conf.py
+@@ -17,7 +17,6 @@ extensions = [
+ "sphinx.ext.coverage",
+ "sphinx.ext.doctest",
+ "sphinx.ext.extlinks",
+- "sphinx.ext.intersphinx",
+ "sphinx.ext.viewcode",
+ ]
+
+@@ -92,10 +91,6 @@
+ 'tornado-%s.tar.g' % version),
+ }
+
+-intersphinx_mapping = {
+- 'python': ('https://docs.python.org/3.5/', None),
+- }
+-
+ on_rtd = os.environ.get('READTHEDOCS', None) == 'True'
+
+ # On RTD we can't import sphinx_rtd_theme, but it will be applied by
diff --git a/www-servers/tornado/files/4.4.1-options-test.patch b/www-servers/tornado/files/4.4.1-options-test.patch
new file mode 100644
index 000000000000..480362647717
--- /dev/null
+++ b/www-servers/tornado/files/4.4.1-options-test.patch
@@ -0,0 +1,13 @@
+diff --git a/tornado/test/options_test.py b/tornado/test/options_test.py
+index f7b215c..c050cb6 100644
+--- a/tornado/test/options_test.py
++++ b/tornado/test/options_test.py
+@@ -36,7 +36,7 @@ class OptionsTest(unittest.TestCase):
+ options.define("port", default=80)
+ options.define("username", default='foo')
+ options.define("my_path")
+- config_path = os.path.join(os.path.dirname(__file__),
++ config_path = os.path.join(os.path.dirname(os.path.abspath(__file__)),
+ "options_test.cfg")
+ options.parse_config_file(config_path)
+ self.assertEqual(options.port, 443)
diff --git a/www-servers/tornado/files/4.5.1-drop-intersphinx.patch b/www-servers/tornado/files/4.5.1-drop-intersphinx.patch
new file mode 100644
index 000000000000..606bfc787381
--- /dev/null
+++ b/www-servers/tornado/files/4.5.1-drop-intersphinx.patch
@@ -0,0 +1,22 @@
+diff -Nur tornado-4.5.1.orig/docs/conf.py tornado-4.5.1/docs/conf.py
+--- tornado-4.5.1.orig/docs/conf.py 2017-06-27 17:39:55.881133239 +0000
++++ tornado-4.5.1/docs/conf.py 2017-06-27 17:40:59.910682166 +0000
+@@ -16,7 +16,6 @@
+ "sphinx.ext.autodoc",
+ "sphinx.ext.coverage",
+ "sphinx.ext.doctest",
+- "sphinx.ext.intersphinx",
+ "sphinx.ext.viewcode",
+ ]
+
+@@ -81,10 +80,6 @@
+ ('index', 'tornado.tex', 'Tornado Documentation', 'The Tornado Authors', 'manual', False),
+ ]
+
+-intersphinx_mapping = {
+- 'python': ('https://docs.python.org/3.5/', None),
+- }
+-
+ on_rtd = os.environ.get('READTHEDOCS', None) == 'True'
+
+ # On RTD we can't import sphinx_rtd_theme, but it will be applied by