summaryrefslogtreecommitdiff
path: root/www-servers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-11 11:06:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-11 11:06:02 +0100
commite93a38d535f2c29b55a5756d2de99425986b0bf3 (patch)
treec0fa85c173d211181d0093e7dc031623e7b8a9a3 /www-servers
parentfbbf0ee3d56a6fd27adf182c6907dc745623aeaa (diff)
gentoo auto-resync : 11:08:2024 - 11:06:01
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/Manifest.gzbin4689 -> 4688 bytes
-rw-r--r--www-servers/gunicorn/Manifest2
-rw-r--r--www-servers/gunicorn/gunicorn-23.0.0.ebuild51
3 files changed, 53 insertions, 0 deletions
diff --git a/www-servers/Manifest.gz b/www-servers/Manifest.gz
index 8f914aa1004a..7ca20c153b8f 100644
--- a/www-servers/Manifest.gz
+++ b/www-servers/Manifest.gz
Binary files differ
diff --git a/www-servers/gunicorn/Manifest b/www-servers/gunicorn/Manifest
index b5c723df9514..571dd1ed7861 100644
--- a/www-servers/gunicorn/Manifest
+++ b/www-servers/gunicorn/Manifest
@@ -1,3 +1,5 @@
DIST gunicorn-22.0.0.gh.tar.gz 368152 BLAKE2B 9d3e2955140d299af86b9370c352d0d7ae2b631a5cdf72200550d3ac8b2e5f51edbc686475d3507f8dfb5f4249ef261e29a6d5fa172e5356777297f5497c7c20 SHA512 cb366cfc2875a32e1e6ddd3bd521650cb87a51c29b036b2cfbd9f8371307d1ffefafbcc85d45753c29186a92def77112e2ddd49fdc2116d2d32702635e88ba53
+DIST gunicorn-23.0.0.gh.tar.gz 373550 BLAKE2B 5f7e74e3554e68863ac32225a95e2e83b69902013bb39f72dbcd150cb30b0698d4fbd2109d1b6e8858fe93b32f4a8aa52fa79cc7346ece769db5426c9caae840 SHA512 1304f348270134a5d9da0d6598f4878a25b3dd7ff96dc9eee1c07ec1031c03cd8bb3de42b6dedf63702588c7e482b18f88a3115e73005bbc4eaaad147d9674ba
EBUILD gunicorn-22.0.0.ebuild 1101 BLAKE2B 252d1bf5fb84872ac4d4c94ee828f4de437be57ba2326912b84b2763baa61aaf18e722a44f17635cc1f576fd572911dc2e3266c1f3879b17e6c45a7a7e06405d SHA512 162868a7cc6ba409c682519077bf129f392b28eccb05f67dbfe0399c3334d5a913f37d796e463a182d53381b250b9292358187f6fc0f6373f1f0e94630f9a38f
+EBUILD gunicorn-23.0.0.ebuild 1109 BLAKE2B 8c3b1b7a1b5b3a2fb24fb8ab8075701b20451173bc0f16aba95bec5dd67a5d188fddb2739d2cdf79fc1ef05c16c4a1e591378a5e0f679de93065a9fd14c30519 SHA512 2b890fb182148a32917f4e8cdab76005ee503e02e74afcd4a07830b281b058e771ea02b6285b18efe9ae492a543e0a7e1615b3eb57ffc0752abf8bbb2e86438a
MISC metadata.xml 715 BLAKE2B 4d0e3c4d2940ee439c3e65bd475421afe9e1eaecc0c3fcb8c543418e78af1c0ab6b0064aff27c95b1006e587a17a40bec6f5314f598cd271a9f456dbcf791b61 SHA512 6bb8ba00899f478cfbda4862f8c86edf272f68f4ce9a48c59297722068e53535805c18b5f5b839e3538e83fb6549ad835f5f900eb5ee4dd06612504a9831c0f9
diff --git a/www-servers/gunicorn/gunicorn-23.0.0.ebuild b/www-servers/gunicorn/gunicorn-23.0.0.ebuild
new file mode 100644
index 000000000000..a19a8dcda301
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-23.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI HTTP Server for UNIX"
+HOMEPAGE="
+ https://gunicorn.org/
+ https://github.com/benoitc/gunicorn/
+ https://pypi.org/project/gunicorn/
+"
+SRC_URI="
+ https://github.com/benoitc/gunicorn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT PSF-2 doc? ( BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.rst )
+
+distutils_enable_sphinx 'docs/source' --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # removed deps
+ tests/workers/test_geventlet.py
+ tests/workers/test_ggevent.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts=
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/source/_build/html/. )
+
+ distutils-r1_python_install_all
+}