summaryrefslogtreecommitdiff
path: root/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild')
-rw-r--r--x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild b/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
index 8662c0102ba5..e87a5ccf4a7a 100644
--- a/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
+++ b/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
EGIT_REPO_URI="https://gitlab.freedesktop.org/drm/${PN}.git"
if [[ ${PV} = *9999* ]]; then
GIT_ECLASS="git-r3"
@@ -88,16 +88,16 @@ src_configure() {
use overlay && use X && overlay_backends+="x,"
local emesonargs=(
- $(meson_feature chamelium build_chamelium)
- $(meson_feature doc build_docs)
- $(meson_feature man build_man)
- $(meson_feature overlay build_overlay)
- $(meson_feature runner build_runner)
- $(meson_feature doc build_tests) # Test build is required for docs
- $(meson_feature valgrind with_valgrind)
- $(meson_feature unwind with_libunwind)
+ $(meson_feature chamelium)
+ $(meson_feature doc docs)
+ $(meson_feature man)
+ $(meson_feature overlay)
+ $(meson_feature runner)
+ $(meson_feature doc tests) # Test build is required for docs
+ $(meson_feature valgrind)
+ $(meson_feature unwind libunwind)
-Doverlay_backends=${overlay_backends%?}
- -Dwith_libdrm=${gpus%?}
+ -Dlibdrm_drivers=${gpus%?}
)
meson_src_configure
}