summaryrefslogtreecommitdiff
path: root/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild')
-rw-r--r--x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild b/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
index 81fff23b3e74..8662c0102ba5 100644
--- a/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
+++ b/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
@@ -88,16 +88,16 @@ src_configure() {
use overlay && use X && overlay_backends+="x,"
local emesonargs=(
- -Dbuild_chamelium=$(usex chamelium true false)
- -Dbuild_docs=$(usex doc true false)
- -Dbuild_man=$(usex man true false)
- -Dbuild_overlay=$(usex overlay true false)
- -Dbuild_runner=$(usex runner true false)
- -Dbuild_tests=$(usex doc true false) # Test build is required for docs
+ $(meson_feature chamelium build_chamelium)
+ $(meson_feature doc build_docs)
+ $(meson_feature man build_man)
+ $(meson_feature overlay build_overlay)
+ $(meson_feature runner build_runner)
+ $(meson_feature doc build_tests) # Test build is required for docs
+ $(meson_feature valgrind with_valgrind)
+ $(meson_feature unwind with_libunwind)
-Doverlay_backends=${overlay_backends%?}
-Dwith_libdrm=${gpus%?}
- -Dwith_libunwind=$(usex unwind true false)
- -Dwith_valgrind=$(usex valgrind true false)
)
meson_src_configure
}