summaryrefslogtreecommitdiff
path: root/x11-apps/luit/luit-20210218.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /x11-apps/luit/luit-20210218.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'x11-apps/luit/luit-20210218.ebuild')
-rw-r--r--x11-apps/luit/luit-20210218.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/x11-apps/luit/luit-20210218.ebuild b/x11-apps/luit/luit-20210218.ebuild
new file mode 100644
index 000000000000..352027e6a1a2
--- /dev/null
+++ b/x11-apps/luit/luit-20210218.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Locale and ISO 2022 support for Unicode terminals"
+HOMEPAGE="https://invisible-island.net/luit/"
+SRC_URI="https://invisible-mirror.net/archives/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="sys-libs/zlib
+ virtual/libiconv"
+RDEPEND="${DEPEND}"
+BDEPEND="sys-apps/groff"
+
+src_configure() {
+ econf --disable-fontenc --enable-iconv
+}