summaryrefslogtreecommitdiff
path: root/x11-apps/radeon-profile-daemon/radeon-profile-daemon-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /x11-apps/radeon-profile-daemon/radeon-profile-daemon-99999999.ebuild
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'x11-apps/radeon-profile-daemon/radeon-profile-daemon-99999999.ebuild')
-rw-r--r--x11-apps/radeon-profile-daemon/radeon-profile-daemon-99999999.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/x11-apps/radeon-profile-daemon/radeon-profile-daemon-99999999.ebuild b/x11-apps/radeon-profile-daemon/radeon-profile-daemon-99999999.ebuild
index ca74330cfd3c..924760fc9099 100644
--- a/x11-apps/radeon-profile-daemon/radeon-profile-daemon-99999999.ebuild
+++ b/x11-apps/radeon-profile-daemon/radeon-profile-daemon-99999999.ebuild
@@ -27,8 +27,14 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${P}/${PN}"
+PATCHES=(
+ "${FILESDIR}/${P}-secure_socket.patch"
+)
+
src_prepare() {
- default
+ eapply -p2 "${PATCHES[@]}"
+ eapply_user
+
sed \
-e '/^bin\.path/s@/bin@/sbin@' \
-e "/^service\.path/s@=.*\$@= $(systemd_get_systemunitdir)@" \
@@ -47,3 +53,8 @@ src_install() {
newinitd "${FILESDIR}"/${PN}.initd ${PN}
}
+
+pkg_postinst() {
+ elog "Users need to be in the \"video\" group if they want to change"
+ elog "video card settings via ${PN}"
+}