summaryrefslogtreecommitdiff
path: root/x11-apps/radeon-profile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /x11-apps/radeon-profile
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'x11-apps/radeon-profile')
-rw-r--r--x11-apps/radeon-profile/Manifest4
-rw-r--r--x11-apps/radeon-profile/metadata.xml11
-rw-r--r--x11-apps/radeon-profile/radeon-profile-20190311.ebuild58
-rw-r--r--x11-apps/radeon-profile/radeon-profile-99999999.ebuild58
4 files changed, 131 insertions, 0 deletions
diff --git a/x11-apps/radeon-profile/Manifest b/x11-apps/radeon-profile/Manifest
new file mode 100644
index 000000000000..4037e9d63f03
--- /dev/null
+++ b/x11-apps/radeon-profile/Manifest
@@ -0,0 +1,4 @@
+DIST radeon-profile-20190311.tar.gz 381505 BLAKE2B e15fbf60f9b790ef81f6b86f74cdada20fe232d2d1965c35248c33bead5f47503780804f0710c8627e4a487e6f95f6688d0dc52b325c278700f9539773547729 SHA512 285ff4fd9f4376135a38009e0e531ec9d9c727840284d9cb4135e0044134a778786559b4280e329be8b78d635928feacd1c0ccc15bce15297d15e4f065460463
+EBUILD radeon-profile-20190311.ebuild 1131 BLAKE2B 778fcd09a31b5169971ec9478ec5796f87fa5f353e3da2503f305720ca15dbd15cc6c3ca41839367ddad71530f49c6ced0277818d0f49ae9a1deee80d674fe57 SHA512 6356218665e24939c9706dc70e680548367709994b3d33018513a96d1b832155302fb33c2c5f5df78aa75dabfaefcc09011b797ee72722a2658ac7547e5ed87a
+EBUILD radeon-profile-99999999.ebuild 1131 BLAKE2B 778fcd09a31b5169971ec9478ec5796f87fa5f353e3da2503f305720ca15dbd15cc6c3ca41839367ddad71530f49c6ced0277818d0f49ae9a1deee80d674fe57 SHA512 6356218665e24939c9706dc70e680548367709994b3d33018513a96d1b832155302fb33c2c5f5df78aa75dabfaefcc09011b797ee72722a2658ac7547e5ed87a
+MISC metadata.xml 351 BLAKE2B 9bd8e162fadd4298b4cad8421104f7a75fcbfd41afba232789443b55e7a0c5befa8da030dc2fdccddedcab6296f51963158bf822e272182d98bf47dde9e63936 SHA512 0dd848bf98523b34bfb961b5711314bfda5294b2e7292a2b9a38c45c3bbb8f3d71ee22640a00068aadf97ee6aec3bf393a288f9d0b0533b7d5c9fa83aeacc2b1
diff --git a/x11-apps/radeon-profile/metadata.xml b/x11-apps/radeon-profile/metadata.xml
new file mode 100644
index 000000000000..127798b95dd1
--- /dev/null
+++ b/x11-apps/radeon-profile/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">marazmista/radeon-profile</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-apps/radeon-profile/radeon-profile-20190311.ebuild b/x11-apps/radeon-profile/radeon-profile-20190311.ebuild
new file mode 100644
index 000000000000..9221aca4ad86
--- /dev/null
+++ b/x11-apps/radeon-profile/radeon-profile-20190311.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+# $Id: 77337142ec368ef43c179461f5ca0beb09d5cd21 $
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="Read current clocks of ATi/AMD Radeon cards"
+HOMEPAGE="https://github.com/marazmista/radeon-profile"
+if [[ "${PV}" == 99999999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/marazmista/radeon-profile.git"
+else
+ SRC_URI="https://github.com/marazmista/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+
+S="${WORKDIR}/${P}/${PN}"
+
+RDEPEND="
+ dev-qt/qtcharts:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ x11-libs/libX11
+ x11-libs/libXrandr
+"
+
+DEPEND="
+ ${RDEPEND}
+ media-libs/mesa
+ x11-libs/libdrm
+"
+
+src_prepare() {
+ default
+ sed 's@TrayIcon;@@' -i extra/${PN}.desktop || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ elog "In order to run ${PN} as non-root user, the"
+ elog " x11-apps/radeon-profile-daemon"
+ elog "package needs to be installed and the daemon must run."
+}
diff --git a/x11-apps/radeon-profile/radeon-profile-99999999.ebuild b/x11-apps/radeon-profile/radeon-profile-99999999.ebuild
new file mode 100644
index 000000000000..9221aca4ad86
--- /dev/null
+++ b/x11-apps/radeon-profile/radeon-profile-99999999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+# $Id: 77337142ec368ef43c179461f5ca0beb09d5cd21 $
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="Read current clocks of ATi/AMD Radeon cards"
+HOMEPAGE="https://github.com/marazmista/radeon-profile"
+if [[ "${PV}" == 99999999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/marazmista/radeon-profile.git"
+else
+ SRC_URI="https://github.com/marazmista/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+
+S="${WORKDIR}/${P}/${PN}"
+
+RDEPEND="
+ dev-qt/qtcharts:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ x11-libs/libX11
+ x11-libs/libXrandr
+"
+
+DEPEND="
+ ${RDEPEND}
+ media-libs/mesa
+ x11-libs/libdrm
+"
+
+src_prepare() {
+ default
+ sed 's@TrayIcon;@@' -i extra/${PN}.desktop || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ elog "In order to run ${PN} as non-root user, the"
+ elog " x11-apps/radeon-profile-daemon"
+ elog "package needs to be installed and the daemon must run."
+}