summaryrefslogtreecommitdiff
path: root/x11-apps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-24 20:48:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-24 20:48:34 +0100
commit9d0673651c57438d51e18c6b8ca894d0491b2df3 (patch)
treec5b6cd187b8998d2c56d3b279ac425973d4c3a33 /x11-apps
parentbe21a4c281fc76681a84dd2f103e850866ce4946 (diff)
gentoo auto-resync : 24:08:2022 - 20:48:33
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/Manifest.gzbin14345 -> 14348 bytes
-rw-r--r--x11-apps/xisxwayland/Manifest4
-rw-r--r--x11-apps/xisxwayland/xisxwayland-2.ebuild29
-rw-r--r--x11-apps/xisxwayland/xisxwayland-9999.ebuild5
4 files changed, 34 insertions, 4 deletions
diff --git a/x11-apps/Manifest.gz b/x11-apps/Manifest.gz
index cdf47789c0d8..f440dcc8d361 100644
--- a/x11-apps/Manifest.gz
+++ b/x11-apps/Manifest.gz
Binary files differ
diff --git a/x11-apps/xisxwayland/Manifest b/x11-apps/xisxwayland/Manifest
index 787d75f455e2..39c8c266ab3e 100644
--- a/x11-apps/xisxwayland/Manifest
+++ b/x11-apps/xisxwayland/Manifest
@@ -1,4 +1,6 @@
DIST xisxwayland-1.tar.xz 4168 BLAKE2B a8e4a658427f5b03e3d05b25772c4f136c13be47a68619a6beab3db72a70e836e495fcbc8a19d5f9347f3336a1dc9b353f483fb75e47ebfdbb9b8409e63444f0 SHA512 9514442313cff4df0c71fed445ba0e3fe52f3c84ebbec81725a590f68cc42ea01ac96b23736a0108fe206da3aee48434c5c30d1c58905bfc75db35205c288bca
+DIST xisxwayland-2.tar.xz 5220 BLAKE2B 47bd626ad2cbeb5b0e114a4f603858c82f4f870f16de038bcadd3010f90e140fb8a3b0531e4102da7527c49bcc6bae6039aa6b42c6182da80467d5a3f040b817 SHA512 b89e19c85a5cd7e62a52e22772f80f03bfea069e31412ca11ac38174c4a2994be559e9d5fb49e6d1921b3f1b06ee71b50ede48990a1e7804a96207b08fc7827f
EBUILD xisxwayland-1.ebuild 657 BLAKE2B 65944553932a15bf773973fabe34c678792a16e9a2fc34dc30bb2badedbbffb125ec608c64c25c276ad907187e324e609d328ae4bf7a46e99746450c6888d984 SHA512 0ee7a3b984ce49d10bb3c5c4df0a1f7c4f53f9aa9a38149f36d4684baefba0e96533b1158b05abf88939faab6b4011b71836298f88ffc223b01a00dac16055ba
-EBUILD xisxwayland-9999.ebuild 658 BLAKE2B efc940d5ec87691440cb8996569402b4384c3a549b410e099a11fa73ed288c5853afdd2cdb2363f15d28c093cd73847787930ecb1fe268ef35893c36e6c5cc69 SHA512 e859e3c45b9cd3260a12fccbf569cac1e0a7d9287fa474d4a5c20eaaccd0dfa3c2d7a5845055ef527d9b9d5cdb77ff1024b6957fd967e6f7ff1c78995d793170
+EBUILD xisxwayland-2.ebuild 655 BLAKE2B cab7cd95e5f719b168637b3b0f3edc4a7c7a32dae2d3d3899baf2f55dbf0ef5ebce2608b0a17a672884c194f815bd5759f78509ef9f55e2633d6ce879570d34e SHA512 deb650604c243b5f78f6449f0129dcff9e5c3adfba516ee55ac63a7f32a8b0c6b5b1b5e44c77bafe9fa5877b95de3f8a738a94348891eb2b4a4487a035c158c1
+EBUILD xisxwayland-9999.ebuild 655 BLAKE2B cab7cd95e5f719b168637b3b0f3edc4a7c7a32dae2d3d3899baf2f55dbf0ef5ebce2608b0a17a672884c194f815bd5759f78509ef9f55e2633d6ce879570d34e SHA512 deb650604c243b5f78f6449f0129dcff9e5c3adfba516ee55ac63a7f32a8b0c6b5b1b5e44c77bafe9fa5877b95de3f8a738a94348891eb2b4a4487a035c158c1
MISC metadata.xml 231 BLAKE2B 6373a9c04316f777f87754fbb7cbc856493138d32bdb05d1015946ebbb359c4b8adb9372554097833d5c9a20e00e32fa0a1c90995d9299dd2215a2cadcccbb73 SHA512 bf6ad5078a6775cd61d257939d41ec53d006124475da2949c55b4b3ac138ec85a88b9068c5920b1e781fadda963939b8f120f8864d82e10cf50e09cc8052a6dc
diff --git a/x11-apps/xisxwayland/xisxwayland-2.ebuild b/x11-apps/xisxwayland/xisxwayland-2.ebuild
new file mode 100644
index 000000000000..aaa53f42f155
--- /dev/null
+++ b/x11-apps/xisxwayland/xisxwayland-2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/app/${PN}.git"
+fi
+
+inherit ${GIT_ECLASS} meson
+
+DESCRIPTION="Tool to determine whether the X server in use is Xwayland"
+HOMEPAGE="https://gitlab.freedesktop.org/xorg/app/xisxwayland"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/app/${P}.tar.xz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
diff --git a/x11-apps/xisxwayland/xisxwayland-9999.ebuild b/x11-apps/xisxwayland/xisxwayland-9999.ebuild
index 9ecc6cb03fe4..aaa53f42f155 100644
--- a/x11-apps/xisxwayland/xisxwayland-9999.ebuild
+++ b/x11-apps/xisxwayland/xisxwayland-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
@@ -21,7 +21,6 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE=""
RDEPEND="
x11-libs/libX11