summaryrefslogtreecommitdiff
path: root/x11-base/xwayland
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-30 03:04:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-10-30 03:04:35 +0000
commitfb57e01054259b1160d01c3c7ed9efab7902ed7d (patch)
tree42985349c49b2294954c1923df85be8bfa0c0957 /x11-base/xwayland
parentbd35a61d88b111f25f4b10126e0d4755545fc7a5 (diff)
gentoo auto-resync : 30:10:2024 - 03:04:35
Diffstat (limited to 'x11-base/xwayland')
-rw-r--r--x11-base/xwayland/Manifest2
-rw-r--r--x11-base/xwayland/xwayland-24.1.4.ebuild133
2 files changed, 135 insertions, 0 deletions
diff --git a/x11-base/xwayland/Manifest b/x11-base/xwayland/Manifest
index 643252579f3a..38c0294683dd 100644
--- a/x11-base/xwayland/Manifest
+++ b/x11-base/xwayland/Manifest
@@ -1,6 +1,8 @@
DIST xwayland-24.1.2.tar.xz 1302068 BLAKE2B 761cc7da4e73da8120d5006ba085808e2c383fa991e29d3948c610671a11fee16295584d59409417ebb216fc8ae23de26d69eda7e453725067229672911ae85e SHA512 2788f6954c999c29be54d5b1e6e2c81327de9fbefae140f7cd322c1ff21f76fdd17cb74cf8243035ea850bfa4573d2013ab895426790b7959cceb7120ba9531c
DIST xwayland-24.1.3.tar.xz 1302164 BLAKE2B 53968bc0eb1ab6ab1d04d195730bbd0961428acfb0178dc592c04bc9bfc3a07cb5ba399377fd1aaaed1153de59d2d35b8b78582a8f7e151912998c3a3cfc6dce SHA512 7e0e11b07408f41a81bafa7bc519d02ed9bdc36e11be16abe255a7d779d04824af23d79323f1602119b046c545cdd43ea91b93e23feb0ffe411aa6989b462c1d
+DIST xwayland-24.1.4.tar.xz 1302372 BLAKE2B 9ca30a423aa5395dda06e3d532a57dc241b4d56bdb0309a47e1075a146f1a7879dde20c46b9c645fc430f534ffe484d0e9448fc9eb74d519f146629176804dc5 SHA512 7d3e4fdf67f07f79d8ddefc0077d10f811fe5ab1f919a922b5afc5dd9843eb2e0bc0a8b225555a0886521eb04a993e06a250469d3594d5add34d6412c76c60f8
EBUILD xwayland-24.1.2.ebuild 2699 BLAKE2B 9b23fe1ba2a9efc518296c1dca0b97392cd0dd55b9208383cef6af5e8845c1c599c1280a32ffdb504c3ea6f018b261a047b336b3869f50d7354421057375a21d SHA512 cfc26ae1f34a7069465b232c1f290a302a92612438347b42f4d26ad1cb41efa692b2f0311790941488943fbdbc4ca221b2e85f02255bba63101c95d42a608f63
EBUILD xwayland-24.1.3.ebuild 2705 BLAKE2B f54170097fdc08c8647412456e57c67caca7d7ac6232316db9c63a4691276b7815dff21a96f3ca1427ccda89adce8fc0b38e0c5d570406a8a0f056e74f025e15 SHA512 d652055dc89bc82c902e8a8f2763d9087998ea8a64f68120e36ce643ab520757a7ec86f870e14685e4dab25469b0f5df612853f2b460ee37b403703501e2aa81
+EBUILD xwayland-24.1.4.ebuild 2705 BLAKE2B f54170097fdc08c8647412456e57c67caca7d7ac6232316db9c63a4691276b7815dff21a96f3ca1427ccda89adce8fc0b38e0c5d570406a8a0f056e74f025e15 SHA512 d652055dc89bc82c902e8a8f2763d9087998ea8a64f68120e36ce643ab520757a7ec86f870e14685e4dab25469b0f5df612853f2b460ee37b403703501e2aa81
EBUILD xwayland-9999.ebuild 2684 BLAKE2B f60153f9a0659ee758f8b77bf2b8956625a0ff86d54bcdd93447ab8c321e2babb84f0f260627105977e43d90ce75a7764580a357a77aea59bc810a4087b9b5b6 SHA512 81e17d04515359bd43209a8cf5b887a6de48c002aacb5a51cfb832ee37ec7af94935e486386854d99d018d5359ee658ad43aeb794d6cff893c8987363b9acf82
MISC metadata.xml 627 BLAKE2B 1d39badd8534a02eb9785acbfa9efa97823c134696d41397d1db294fa774da9b4f184e027dada1b718cff3d651c9b436a4812458abef1d70af4d7749963d822a SHA512 9d02c7a263144ecfa9aac594867efee3622823b264fc3305e11c4b396156f0c43b071804f6f0ae9850b67b09ae887d270a722b9c4c4482e5ea962eedb915ee79
diff --git a/x11-base/xwayland/xwayland-24.1.4.ebuild b/x11-base/xwayland/xwayland-24.1.4.ebuild
new file mode 100644
index 000000000000..9eecb443ea90
--- /dev/null
+++ b/x11-base/xwayland/xwayland-24.1.4.ebuild
@@ -0,0 +1,133 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
+ inherit git-r3
+else
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/xserver/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Standalone X server running under Wayland"
+HOMEPAGE="https://wayland.freedesktop.org/xserver.html"
+
+LICENSE="MIT"
+SLOT="0"
+
+IUSE="libei selinux systemd test unwind xcsecurity"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/libbsd
+ dev-libs/openssl:=
+ >=dev-libs/wayland-1.21.0
+ >=dev-libs/wayland-protocols-1.34
+ media-fonts/font-util
+ >=media-libs/libepoxy-1.5.4[X,egl(+)]
+ media-libs/libglvnd[X]
+ >=media-libs/mesa-21.1[X(+),egl(+),gbm(+)]
+ >=x11-libs/libdrm-2.4.116
+ >=x11-libs/libXau-1.0.4
+ x11-libs/libxcvt
+ >=x11-libs/libXdmcp-1.0.2
+ >=x11-libs/libXfont2-2.0.1
+ x11-libs/libxkbfile
+ >=x11-libs/libxshmfence-1.1
+ >=x11-libs/pixman-0.27.2
+ >=x11-misc/xkeyboard-config-2.4.1-r3
+
+ libei? ( dev-libs/libei )
+ systemd? ( sys-apps/systemd )
+ unwind? ( sys-libs/libunwind )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ >=x11-base/xorg-proto-2024.1
+ >=x11-libs/xtrans-1.3.5
+ test? (
+ x11-misc/rendercheck
+ x11-libs/libX11
+ )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ x11-apps/xkbcomp
+
+ libei? ( >=sys-apps/xdg-desktop-portal-1.18.0 )
+ selinux? ( sec-policy/selinux-xserver )
+"
+BDEPEND="
+ app-alternatives/lex
+ dev-util/wayland-scanner
+"
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ sed -i -e "s/dependency('x11')/disabler()/" meson.build || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use selinux xselinux)
+ $(meson_use systemd systemd_notify)
+ $(meson_use unwind libunwind)
+ $(meson_use xcsecurity)
+ -Ddpms=true
+ -Ddri3=true
+ -Ddrm=true
+ -Ddtrace=false
+ -Dglamor=true
+ -Dglx=true
+ -Dipv6=true
+ -Dsecure-rpc=false
+ -Dscreensaver=true
+ -Dsha1=libcrypto
+ -Dxace=true
+ -Dxdmcp=true
+ -Dxinerama=true
+ -Dxvfb=true
+ -Dxv=true
+ -Dxwayland-path="${EPREFIX}"/usr/bin
+ -Dlibdecor=false
+ -Ddocs=false
+ -Ddevel-docs=false
+ -Ddocs-pdf=false
+ )
+
+ if [[ ${PV} == "9999" ]]; then
+ emesonargs+=(
+ -Dxorg=false
+ -Dxnest=false
+ -Dxvfb=false
+ -Dxwayland=true
+ )
+ fi
+
+ if use libei; then
+ emesonargs+=( -Dxwayland_ei=portal )
+ else
+ emesonargs+=( -Dxwayland_ei=false )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ dosym ../bin/Xwayland /usr/libexec/Xwayland
+
+ meson_src_install
+
+ # Remove files installed by x11-base/xorg-xserver
+ rm \
+ "${ED}"/usr/share/man/man1/Xserver.1 \
+ "${ED}"/usr/$(get_libdir)/xorg/protocol.txt \
+ || die
+}