summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-wacom
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-31 03:04:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-10-31 03:04:18 +0000
commitb846e1a1ef5685462a20abbc77cf57ead9064b85 (patch)
treeebf4581a96d87fbd1b7ab6cce8689ba4caa40e3b /x11-drivers/xf86-input-wacom
parentfb57e01054259b1160d01c3c7ed9efab7902ed7d (diff)
gentoo auto-resync : 31:10:2024 - 03:04:18HEADmaster
Diffstat (limited to 'x11-drivers/xf86-input-wacom')
-rw-r--r--x11-drivers/xf86-input-wacom/Manifest2
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-1.2.3.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-wacom/Manifest b/x11-drivers/xf86-input-wacom/Manifest
index c55c8aed7365..b8843af7cbd6 100644
--- a/x11-drivers/xf86-input-wacom/Manifest
+++ b/x11-drivers/xf86-input-wacom/Manifest
@@ -1,3 +1,5 @@
DIST xf86-input-wacom-1.2.2.tar.bz2 649132 BLAKE2B c068317c7ca74dbda336f12c96cf27f7541880aa75f65638d72755d28538614d72e091ca94a7c62c84e5748ebfa459fe3f930edcd55e53797301719630055e8f SHA512 60c490ff67ff6b4719a2683f5368ef3fca3d97ced92cf251bb4c7610d24e9df1d3577f50b625621025b2e2d1abf8f8aac2dbb7629220664992f6b85a0a84adcb
+DIST xf86-input-wacom-1.2.3.tar.bz2 674630 BLAKE2B a3556579d88ec2b35e60928c6429ef0a374afe6a1873e70fca655c31749cc749810b7e348f075a3d8459ec6278ba5d67c7754cfe58b4050e112a5eef2e26da0c SHA512 1419f0d3103025d2f5d0b88b74c29f9b7cb9eb4f05119f8a469384af12b2821653596ce5adac918d8875e622cfccbd47ea9c6fc43d28c72091b09ec674e22de9
EBUILD xf86-input-wacom-1.2.2.ebuild 1339 BLAKE2B 95128c73ae371bf005b08efb0dd6c4399cdfcd31fcf385eff82bd2e342a7da497c333e6f92704447fc3a0309b2f60694ed43b824b5f22f24a189698db1114664 SHA512 3f46bd06ffb48ddc316ef239f508314d6af82f573f780432d33b2e41b914c62353022d866a142ac610a2d03305f8bc2970ee51356f0f9cb22a3bf665664599eb
+EBUILD xf86-input-wacom-1.2.3.ebuild 1346 BLAKE2B f3c96ad2001793e628a313bfd90782e7614bdb8a915265816300765b25ef47b07710e74c00ba6de3f8c0b72d25807f25bb67c31c87b8e39fee19fce10678c007 SHA512 8e9a9045193e81db8d42b3fcde96e29f28451febd2472dd0b4408b513efd10c1c112bdc3c83e1cfb97d8cd5c929be70a8d156097f887195968f16ab741fbdf75
MISC metadata.xml 337 BLAKE2B 4af5fa6cfa58ef6ecec60cbe9f316cc4adfa0b1eb304d2c1fe4525b916e1c347bd3b9a74c2e79a5bb88649aae92f00b624c619169fc8cb6ac81e359e58c53d2b SHA512 fba2d6d8bbfe90c65794dd1b831c6bad7dcd2b6e67036f46d629f4e85f926409b7fba0e99892ce7a2ce527fd080d5e75467d0ec38fee0ea2f7ecd311c2c49893
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.2.3.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.2.3.ebuild
new file mode 100644
index 000000000000..e1af227b997d
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.2.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info systemd udev xorg-3 meson
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="https://linuxwacom.github.io/"
+SRC_URI="https://github.com/linuxwacom/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXinerama
+ virtual/libudev:="
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present HID_WACOM; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " HID support --->"
+ ewarn " Special HID drivers --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ xorg-3_flags_setup
+
+ local emesonargs=(
+ -Dsystemd-unit-dir="$(systemd_get_systemunitdir)"
+ -Dudev-rules-dir="$(get_udevdir)/rules.d"
+ $(meson_feature test unittests)
+ -Dwacom-gobject=disabled
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}