summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-12 06:32:46 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-12 06:32:46 +0100
commit28e3d252dc8ac8a5635206dfefe1cfe05058d1db (patch)
treee75bce604750fb72e53ed3684059e2e5d2094509 /x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
parentf625b9919a60a30f1bd860f7d1b2eac183ced593 (diff)
gentoo resync : 12.08.2018
Diffstat (limited to 'x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild')
-rw-r--r--x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild51
1 files changed, 11 insertions, 40 deletions
diff --git a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
index 1045c31be890..90a061997083 100644
--- a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
+++ b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
@@ -1,52 +1,23 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=5
+XORG_DRI="always"
+inherit xorg-2
-DESCRIPTION="Accelerated Open Source driver for AMDGPU cards"
-HOMEPAGE="https://www.x.org/wiki/ https://cgit.freedesktop.org/"
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/driver/xf86-video-amdgpu.git"
- inherit autotools git-r3
- LIVE_DEPEND=">=x11-misc/util-macros-1.18"
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
else
- SRC_URI="mirror://xorg/driver/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
fi
-LICENSE="MIT"
-SLOT="0"
-IUSE=""
-
-BDEPEND="
- virtual/pkgconfig
-"
-RDEPEND="
- >=x11-libs/libdrm-2.4.78[video_cards_amdgpu]
- x11-libs/libpciaccess
- x11-base/xorg-server:=[glamor(-),-minimal]
-"
-DEPEND="
- ${LIVE_DEPEND}
- ${RDEPEND}
-"
+DESCRIPTION="Accelerated Open Source driver for AMDGPU cards"
-src_prepare() {
- default
- [[ ${PV} == 9999 ]] && eautoreconf
-}
+RDEPEND=">=x11-libs/libdrm-2.4.78[video_cards_amdgpu]
+ x11-base/xorg-server[glamor(-)]"
+DEPEND="${RDEPEND}"
src_configure() {
- local econfargs=(
- --disable-selective-werror
- --enable-glamor
- )
-
- econf "${econfargs[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
+ XORG_CONFIGURE_OPTIONS="--enable-glamor"
+ xorg-2_src_configure
}