summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-10 03:19:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-10 03:19:26 +0000
commitcaf79cb4f7c4d5f7cce488d8f50dfb98ddbd09ab (patch)
tree4fb39a9252efabe8f160ef46b7b3be2f52af25aa /x11-drivers/xf86-video-vesa/xf86-video-vesa-2.6.0.ebuild
parent3606ceecb950b302a6ba2a9882aeeff2a851e5dc (diff)
gentoo auto-resync : 10:12:2022 - 03:19:26
Diffstat (limited to 'x11-drivers/xf86-video-vesa/xf86-video-vesa-2.6.0.ebuild')
-rw-r--r--x11-drivers/xf86-video-vesa/xf86-video-vesa-2.6.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.6.0.ebuild b/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.6.0.ebuild
new file mode 100644
index 000000000000..a74450947e1d
--- /dev/null
+++ b/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.6.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit linux-info xorg-3
+
+DESCRIPTION="Generic VESA video driver"
+KEYWORDS="-* ~alpha ~amd64 ~x86"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists || ! linux_chkconfig_present DEVMEM; then
+ echo
+ ewarn "This driver requires /dev/mem support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Character devices --->"
+ ewarn " [*] /dev/mem virtual device support"
+ echo
+ fi
+}