summaryrefslogtreecommitdiff
path: root/x11-libs/cairo/cairo-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /x11-libs/cairo/cairo-9999.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'x11-libs/cairo/cairo-9999.ebuild')
-rw-r--r--x11-libs/cairo/cairo-9999.ebuild27
1 files changed, 13 insertions, 14 deletions
diff --git a/x11-libs/cairo/cairo-9999.ebuild b/x11-libs/cairo/cairo-9999.ebuild
index f2e28c9ed364..d5022d1759a3 100644
--- a/x11-libs/cairo/cairo-9999.ebuild
+++ b/x11-libs/cairo/cairo-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils flag-o-matic autotools multilib-minimal
+inherit flag-o-matic autotools multilib-minimal
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -18,13 +18,16 @@ DESCRIPTION="A vector graphics library with cross-device output support"
HOMEPAGE="https://www.cairographics.org/ https://gitlab.freedesktop.org/cairo/cairo"
LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
SLOT="0"
-IUSE="X aqua debug gles2 +glib opengl static-libs +svg utils valgrind xcb"
+IUSE="X aqua debug gles2-only +glib opengl static-libs +svg utils valgrind"
# gtk-doc regeneration doesn't seem to work with out-of-source builds
#[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
RESTRICT="test"
+BDEPEND="
+ virtual/pkgconfig
+ >=sys-devel/libtool-2"
RDEPEND="
>=dev-libs/lzo-2.06-r1[${MULTILIB_USEDEP}]
>=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}]
@@ -33,20 +36,16 @@ RDEPEND="
sys-libs/binutils-libs:0=[${MULTILIB_USEDEP}]
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
>=x11-libs/pixman-0.32.4[${MULTILIB_USEDEP}]
- gles2? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
+ gles2-only? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
opengl? ( >=media-libs/mesa-9.1.6[egl,X(+),${MULTILIB_USEDEP}] )
X? (
>=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
>=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
>=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
- )
- xcb? (
>=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
)"
DEPEND="${RDEPEND}
- virtual/pkgconfig
- >=sys-devel/libtool-2
X? ( x11-base/xorg-proto )"
#[[ ${PV} == *9999* ]] && DEPEND="${DEPEND}
# doc? (
@@ -55,7 +54,7 @@ DEPEND="${RDEPEND}
# )"
REQUIRED_USE="
- gles2? ( !opengl )
+ gles2-only? ( !opengl )
"
PATCHES=(
@@ -97,24 +96,24 @@ multilib_src_configure() {
$(use_enable X tee) \
$(use_enable X xlib) \
$(use_enable X xlib-xrender) \
+ $(use_enable X xcb) \
+ $(use_enable X xcb-shm) \
$(use_enable aqua quartz) \
$(use_enable aqua quartz-image) \
$(use_enable debug test-surfaces) \
- $(use_enable gles2 glesv2) \
+ $(use_enable gles2-only glesv2) \
$(use_enable glib gobject) \
$(use_enable opengl gl) \
$(use_enable static-libs static) \
$(use_enable svg) \
$(use_enable utils trace) \
$(use_enable valgrind) \
- $(use_enable xcb) \
- $(use_enable xcb xcb-shm) \
--enable-ft \
+ --enable-interpreter \
--enable-pdf \
--enable-png \
--enable-ps \
--enable-script \
- --enable-interpreter \
--disable-drm \
--disable-directfb \
--disable-gallium \
@@ -125,6 +124,6 @@ multilib_src_configure() {
}
multilib_src_install_all() {
- prune_libtool_files --all
+ find "${D}" -name '*.la' -delete || die
einstalldocs
}