summaryrefslogtreecommitdiff
path: root/x11-libs/colord-gtk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /x11-libs/colord-gtk
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'x11-libs/colord-gtk')
-rw-r--r--x11-libs/colord-gtk/Manifest3
-rw-r--r--x11-libs/colord-gtk/colord-gtk-0.2.0.ebuild59
-rw-r--r--x11-libs/colord-gtk/files/colord-gtk-0.2.0-optional-introspection.patch41
3 files changed, 103 insertions, 0 deletions
diff --git a/x11-libs/colord-gtk/Manifest b/x11-libs/colord-gtk/Manifest
index d94a4c96cbaf..0d7de83f6ff8 100644
--- a/x11-libs/colord-gtk/Manifest
+++ b/x11-libs/colord-gtk/Manifest
@@ -1,3 +1,6 @@
+AUX colord-gtk-0.2.0-optional-introspection.patch 1471 BLAKE2B 3d4ce65f6241538fc4f8b6114c95ef229654093dabed26ebf1c66aabda2d5039749cce8580a4974c70afdd49e127b791a561a04202338c9b6512870804bce4db SHA512 a49618d773acb377c8015243ac6657e17b65e1f0f54228c391617118ae61199662a6d6398d5c5cd02ceb4cc74dc2b4cedf6488536fbe418768480285c5500773
DIST colord-gtk-0.1.26.tar.xz 280380 BLAKE2B 6ddd52b81726f21a2c376b1ab0c773f7670859882f3e5fe6038bf8728d5a9f3308b469b4e563dc784873b5b9cbed8ca671552e9bcb9cbccfaf28cd8f85e0b5bd SHA512 14f59110e2bc100c542323a68566102e9fb5ab44b679da21bf29101960dae38e646e926d884e14f1838a5991e6ebe15af72d5338723265868eadd5f026545c3d
+DIST colord-gtk-0.2.0.tar.xz 20480 BLAKE2B 73bbb349e84e5bfd28358cbe22609de84b86f90eb96a3fedc6e30a1764d9c667cd82408116cdf65591496ab4e2f59f2b415cd1aa8f995fe2162ee4d649c5d496 SHA512 797eebfd4451fcae4cf70835f5de3d9bdc9e8401ddb82a2fef2310002f28bf523b599c587ff35eb89ceff38a245a6311129ad90b107f837ac4f42f268c9aad97
EBUILD colord-gtk-0.1.26.ebuild 1657 BLAKE2B 60f3e47850b590f53ebb2bd6abf4a85625d9ba83178b88abfdaf522415968af32d19e7a540b2aa60ef6657d88bedb56a4d880362422bf352bfa46ed695747378 SHA512 22e5159dfd7c1cf21897ff4a27147cc30db2e77f3bb9287579931b6a8eecbc7c1d51f150a8075e2b052d4f79a09e78b4dcf941922f3d378a7f7067aebe2edd6d
+EBUILD colord-gtk-0.2.0.ebuild 1308 BLAKE2B 1eba533efbe58238f331951f51a6dce7a198047066fafd7796c56725b9106e5eac7c5f29ee437fdc2f5ae0982f6f430b5b397900a49278751468c1ed5c53c3b6 SHA512 e9b90314c0ec41b19bee04648a165ebe65c5b4523d3e3d1c680640763d38f87060165ebcb73c8b3d10940895089c5016b095ebe7803d0b527d43dac98ee511f6
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/x11-libs/colord-gtk/colord-gtk-0.2.0.ebuild b/x11-libs/colord-gtk/colord-gtk-0.2.0.ebuild
new file mode 100644
index 000000000000..d1ec57ccb2bc
--- /dev/null
+++ b/x11-libs/colord-gtk/colord-gtk-0.2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit meson vala
+
+DESCRIPTION="GTK support library for colord"
+HOMEPAGE="https://www.freedesktop.org/software/colord/"
+SRC_URI="https://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0/1" # subslot = libcolord-gtk soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.28:2
+ x11-libs/gtk+:3[introspection?]
+ >=x11-misc/colord-0.1.27:=[introspection?,vala?]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/libxslt
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gtk-doc-1.9
+ )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8 )
+ vala? ( $(vala_depend) )
+"
+
+RESTRICT="test" # Tests need a display device with a default color profile set
+
+PATCHES=(
+ "${FILESDIR}/${P}-optional-introspection.patch"
+)
+
+src_prepare() {
+ use vala && vala_src_prepare
+ default
+}
+
+src_configure() {
+ local -a emesonargs=(
+ -Dgtk2=false
+ -Dman=true
+ -Dtests=false
+ $(meson_use doc docs)
+ $(meson_use introspection)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}
diff --git a/x11-libs/colord-gtk/files/colord-gtk-0.2.0-optional-introspection.patch b/x11-libs/colord-gtk/files/colord-gtk-0.2.0-optional-introspection.patch
new file mode 100644
index 000000000000..543b443e3aec
--- /dev/null
+++ b/x11-libs/colord-gtk/files/colord-gtk-0.2.0-optional-introspection.patch
@@ -0,0 +1,41 @@
+From 0fb3425873a04ba100b57d59449d27bba6768ff3 Mon Sep 17 00:00:00 2001
+From: David Michael <fedora.dm0@gmail.com>
+Date: Sat, 9 Jan 2021 14:42:39 -0500
+Subject: [PATCH] Make introspection optional in meson
+
+It defaults to enabled to preserve existing behavior.
+---
+ libcolord-gtk/meson.build | 2 ++
+ meson_options.txt | 1 +
+ 2 files changed, 3 insertions(+)
+
+diff --git a/libcolord-gtk/meson.build b/libcolord-gtk/meson.build
+index c4fe704..18f36a0 100644
+--- a/libcolord-gtk/meson.build
++++ b/libcolord-gtk/meson.build
+@@ -61,6 +61,7 @@ pkgg.generate(
+ description : 'colord-gtk is GTK integration for libcolord',
+ )
+
++if get_option('introspection')
+ libcolord_gtk_gir = gnome.generate_gir(
+ colord_gtk,
+ sources : [
+@@ -97,6 +98,7 @@ libcolord_gtk_gir = gnome.generate_gir(
+ ],
+ install : true
+ )
++endif
+
+ if get_option('vapi')
+ gnome.generate_vapi(
+diff --git a/meson_options.txt b/meson_options.txt
+index 1c3cecc..a4efa84 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -1,4 +1,5 @@
+ option('gtk2', type : 'boolean', value : false, description : 'Build Gtk2 library')
++option('introspection', type : 'boolean', value : true, description : 'Build gobject-introspection typelib files')
+ option('vapi', type : 'boolean', value : false, description : 'Build vala bindings')
+ option('tests', type : 'boolean', value : true, description : 'Build self tests')
+ option('man', type : 'boolean', value : true, description : 'Generate man pages')