summaryrefslogtreecommitdiff
path: root/x11-libs/dnd/dnd-1.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-22 14:00:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-22 14:00:47 +0100
commit91c0ec2d7067f6ab1ef578bd9967b32ca07eb502 (patch)
treef4c7f54d0aeb344c21de9b9d1a3f1e9826d7a64c /x11-libs/dnd/dnd-1.1-r3.ebuild
parent2bacbb3374587799c77a999f56352233a353b19e (diff)
gentoo resync : 22.05.2018
Diffstat (limited to 'x11-libs/dnd/dnd-1.1-r3.ebuild')
-rw-r--r--x11-libs/dnd/dnd-1.1-r3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-libs/dnd/dnd-1.1-r3.ebuild b/x11-libs/dnd/dnd-1.1-r3.ebuild
new file mode 100644
index 000000000000..db03f5042758
--- /dev/null
+++ b/x11-libs/dnd/dnd-1.1-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="OffiX' Drag'n'drop library"
+HOMEPAGE="http://leb.net/offix"
+SRC_URI="http://leb.net/offix/${PN}.${PV}.tgz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm64 ~hppa ~ia64 ~ppc ppc64 sparc x86"
+
+RDEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.diff
+ "${FILESDIR}"/Makefile-fix.patch
+)
+
+S="${WORKDIR}/DND/DNDlib"
+
+src_configure() {
+ tc-export CC CXX RANLIB AR
+ econf --with-x
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+}