summaryrefslogtreecommitdiff
path: root/x11-libs/gdk-pixbuf-loader-webp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-libs/gdk-pixbuf-loader-webp
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-libs/gdk-pixbuf-loader-webp')
-rw-r--r--x11-libs/gdk-pixbuf-loader-webp/Manifest3
-rw-r--r--x11-libs/gdk-pixbuf-loader-webp/gdk-pixbuf-loader-webp-20160328234507.ebuild38
-rw-r--r--x11-libs/gdk-pixbuf-loader-webp/metadata.xml22
3 files changed, 63 insertions, 0 deletions
diff --git a/x11-libs/gdk-pixbuf-loader-webp/Manifest b/x11-libs/gdk-pixbuf-loader-webp/Manifest
new file mode 100644
index 000000000000..e4ba12d89d45
--- /dev/null
+++ b/x11-libs/gdk-pixbuf-loader-webp/Manifest
@@ -0,0 +1,3 @@
+EBUILD gdk-pixbuf-loader-webp-20160328234507.ebuild 767 SHA256 d3a9442c97164d9bd72d4b4e2ecfe1e0724d56b693144f18c44222cc87628d67 SHA512 0232872cbbf2b1faa1adca1b4a562aee13d16bd637013ff271b49bfaa05afd99bfa8ebca99d08010d72c32a0a86d364e6ccd84e7208d6ebcfd80b9bd0c38e23b WHIRLPOOL 034c7a23713de589b031dc4b217a0b9b2b81accf9d3e978116f4514e804ec5594b2f09fe9b3fe3445e35c761460b56d2366f5a6e67da94e4268085ffe889a5cd
+MISC ChangeLog 638 SHA256 f3f3c725a9086a7c7b4acd206dea7d40da03d6e9db9dfc0ed1dd32bd2fc3a420 SHA512 bb498c91ddfc08114352dbbe668ef80d437be33b688262dcafd5b99c79e3117a6baf72eb69ee705983e987ab2189cf72e579a6bf00d799079dc2221c88ec7a8d WHIRLPOOL 61064870bd0791ef122d5924925fd895ad664506c8272281bd415779960f83342972e63fb2161f9287e7804478dca4351c438a9786222c8d55ac1bd9727b7608
+MISC metadata.xml 697 SHA256 9bfadd254768d4deb8f40c20cc813ccc967f23292cc0b3940e920ea2191676e5 SHA512 6a7253f9eb7b46f8de174963e5cb30d5b9b1d4d7ef915fa2fa210e792b3b8927039d325aa5be03042998023f98508becc40f6f92b4b002ff5021dd8c49c7228a WHIRLPOOL c36b04869b0063dec53fa4fbfc4707567f8df4ee654556a7642fa7b201ee5142faef0b8c48d89718ccf897f778a957607e2ec88a749d66cf6d8957aaa4d0641c
diff --git a/x11-libs/gdk-pixbuf-loader-webp/gdk-pixbuf-loader-webp-20160328234507.ebuild b/x11-libs/gdk-pixbuf-loader-webp/gdk-pixbuf-loader-webp-20160328234507.ebuild
new file mode 100644
index 000000000000..8ec1d797cd9a
--- /dev/null
+++ b/x11-libs/gdk-pixbuf-loader-webp/gdk-pixbuf-loader-webp-20160328234507.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/aruiz/webp-pixbuf-loader"
+EGIT_COMMIT=9b92950d49d7939f90ba7413deb7ec6b392b2054
+
+inherit git-r3 cmake-multilib gnome2-utils
+
+DESCRIPTION="WebP Image format GdkPixbuf loader"
+HOMEPAGE="https://github.com/aruiz/webp-pixbuf-loader"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=">=media-libs/libwebp-0.4.3
+ >=x11-libs/gdk-pixbuf-2.22"
+RDEPEND="${DEPEND}"
+
+multilib_src_configure() {
+ local mycmakeargs=( -DINSTALL_LIB_DIR:PATH=$(get_libdir) )
+ cmake-utils_src_configure
+}
+
+pkg_preinst() {
+ gnome2_gdk_pixbuf_savelist
+}
+
+pkg_postinst() {
+ gnome2_gdk_pixbuf_update
+}
+
+pkg_postinst() {
+ gnome2_gdk_pixbuf_update
+}
diff --git a/x11-libs/gdk-pixbuf-loader-webp/metadata.xml b/x11-libs/gdk-pixbuf-loader-webp/metadata.xml
new file mode 100644
index 000000000000..00f1f8a2cff9
--- /dev/null
+++ b/x11-libs/gdk-pixbuf-loader-webp/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andy.kittner@gmail.com</email>
+ <name>Andy Kittner</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>graphics@gentoo.org</email>
+ <name>Gentoo Graphics Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ A gdk-pixbuf plugin that allows GTK applications to view webp images.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">aruiz/webp-pixbuf-loader</remote-id>
+ </upstream>
+</pkgmetadata>