summaryrefslogtreecommitdiff
path: root/x11-libs/goocanvas
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /x11-libs/goocanvas
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'x11-libs/goocanvas')
-rw-r--r--x11-libs/goocanvas/Manifest3
-rw-r--r--x11-libs/goocanvas/goocanvas-2.0.4-r2.ebuild57
-rw-r--r--x11-libs/goocanvas/goocanvas-3.0.0.ebuild57
3 files changed, 117 insertions, 0 deletions
diff --git a/x11-libs/goocanvas/Manifest b/x11-libs/goocanvas/Manifest
index 9d09ae849692..e160c90e5b9f 100644
--- a/x11-libs/goocanvas/Manifest
+++ b/x11-libs/goocanvas/Manifest
@@ -1,3 +1,6 @@
DIST goocanvas-2.0.4.tar.xz 584272 BLAKE2B 027ab47c1e9c241f74509001426367e86025ec8ea5901cf64c2014f8c32b83ce60870ca754dd15e8982a7023b77d3856b39dbbbdd636de6da47d361cb15a940e SHA512 e57dfd59d9b9cb64deadfeac193c11a89347c7f0e966377cfb98afcc2b46be13fe05d253a96e63dc7e6981c75e6e871040b83d8d0aee95cb62b79965d6be5688
+DIST goocanvas-3.0.0.tar.xz 556832 BLAKE2B 4ee632a614b6b881000bbee8d5e21a166151a94667c603c92b94c5e076fab78a6df44fe1d45fb4d7c4d65c0e060b599abf3970313542836a63efbca33d6a075b SHA512 a53839af4d98afdfc0f92531bdb09013dd71e964185dc2670af077bb7b41b9ff5c75f2801f6e77c99055b38f3603d8cf197f84affb8d7c3196526ce824b228e3
EBUILD goocanvas-2.0.4-r1.ebuild 1289 BLAKE2B 6b0a74060e137eaacee6a6402fec2277d6ef9cbbcc7a765f249316e1d48c3c7fcfc9e0442f607bf7dc11687f5264222617a902da815530216e9c72ad80f3b7fc SHA512 7b87bdf8645a9090eaddec1bdf4e9ed151eb8e377a3e0c8094a281374855657f0e05312a4c22c5990c5f5ceb179deb0d053a33595aa8da765a9e0873d724b49b
+EBUILD goocanvas-2.0.4-r2.ebuild 1282 BLAKE2B d39ce74332a8f817b8774b49a6a411b524e964f04cc375965107cf4674d02681684c37b8f15e41ad319b635d169052dcb1996a226a31d6fd8fbf632d766f6df5 SHA512 6ee2c7caa4de06e935ec86d887a9494badd4cac4a53d86625257d3bed22ee4ef247957e6451342e94b34fff1940916ae4f03649b040cf4144abe46ea32219520
+EBUILD goocanvas-3.0.0.ebuild 1282 BLAKE2B e040b8dcf262c63b80dbb4c4b0e867c0a19596fafdbcf5100931ea0de41288d89323b98141f3a587a2fb227970cf5497967897e362a960e5ef2dc293aaa990b4 SHA512 b4e555ea8033ce6455873b511777fb2f1514877563d1f4a9f6bcd80101c5b11f736592824fc7652c4fd43bfc692eee4fd47242c8c4be0cee10943052d3248ed2
MISC metadata.xml 250 BLAKE2B 8f7f0fe023d43e380e7861e897e6afcb5de4baefb42ea9c65a57dfc0d204c6f787a99295141832e732ebb08be218da56ba77e2dd9639e4e3aabf718ce4db1d0c SHA512 2684e772dd6d83e4b49f08f2ba22d8a0a753e7b46863489eff1b5d1f2f147ad80ffd93245ca405ac4c747249bc1b754454ec9865fe16da70f9b257051e105fd8
diff --git a/x11-libs/goocanvas/goocanvas-2.0.4-r2.ebuild b/x11-libs/goocanvas/goocanvas-2.0.4-r2.ebuild
new file mode 100644
index 000000000000..73563a3e29f3
--- /dev/null
+++ b/x11-libs/goocanvas/goocanvas-2.0.4-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="Canvas widget for GTK+ using the cairo 2D library for drawing"
+HOMEPAGE="https://wiki.gnome.org/GooCanvas"
+
+LICENSE="LGPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples +introspection"
+
+RDEPEND="
+ >=x11-libs/cairo-1.10.0
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.0.0:3
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.16
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not build demos
+ sed -e 's/^\(SUBDIRS =.*\)demo\(.*\)$/\1\2/' \
+ -i Makefile.{am,in} || die "Failed to sed demo"
+
+ # Python bindings are built/installed manually, but not at all anymore (py2).
+ sed -e "/SUBDIRS = python/d" \
+ -i bindings/Makefile.{am,in} || die "Failed to sed python subdirs"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ PYTHON=true gnome2_src_configure \
+ --disable-rebuilds \
+ --disable-static \
+ $(use_enable introspection) \
+ --disable-python
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto "/usr/share/doc/${P}/examples/"
+ doins demo/*.[ch] demo/*.png
+ fi
+}
diff --git a/x11-libs/goocanvas/goocanvas-3.0.0.ebuild b/x11-libs/goocanvas/goocanvas-3.0.0.ebuild
new file mode 100644
index 000000000000..16b18094e850
--- /dev/null
+++ b/x11-libs/goocanvas/goocanvas-3.0.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="Canvas widget for GTK+ using the cairo 2D library for drawing"
+HOMEPAGE="https://wiki.gnome.org/GooCanvas"
+
+LICENSE="LGPL-2"
+SLOT="3.0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples +introspection"
+
+RDEPEND="
+ >=x11-libs/cairo-1.10.0
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.0.0:3
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.16
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not build demos
+ sed -e 's/^\(SUBDIRS =.*\)demo\(.*\)$/\1\2/' \
+ -i Makefile.{am,in} || die "Failed to sed demo"
+
+ # Python bindings are built/installed manually, but not at all anymore (py2).
+ sed -e "/SUBDIRS = python/d" \
+ -i bindings/Makefile.{am,in} || die "Failed to sed python subdirs"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ PYTHON=true gnome2_src_configure \
+ --disable-rebuilds \
+ --disable-static \
+ $(use_enable introspection) \
+ --disable-python
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto "/usr/share/doc/${P}/examples/"
+ doins demo/*.[ch] demo/*.png
+ fi
+}